cancel
Showing results for 
Search instead for 
Did you mean: 

Integration as Marketplace Extension issue (Extension submit and "no matching package found")

Occasional Visitor

Integration as Marketplace Extension issue (Extension submit and "no matching package found")

Hi everyone.

I'm developing an Integration extension for my client.

Got a working module according to the article in the documentation: Create an integration

 

There are instructions on using composer.json, which is understandable. The following dependencies are indicated there:

"require": {
    "php": "~5.5.0|~5.6.0|~7.0.0",
    "magento/framework": "2.0.0",
    "magento/module-integration": "2.0.0"
},

But I'm getting an error when uploading the extension (Submit for Technical Review):

magento/module-integration 2.0.0 -> no matching package found
Errors during installation
Command:
composer require %VENDORNAME%/%EXTENSIONNAME%:1.0.0'
Installation issue:
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for %VENDORNAME%/%EXTENSIONNAME% 1.0.0-> satisfiable by %VENDORNAME%/%EXTENSIONNAME%[1.0.0].
- %VENDORNAME%/%EXTENSIONNAME% 1.0.0 requires magento/module-integration 2.0.0 -> no matching package found.

The same with 

"magento/framework": "2.0.0"

These requirements in the documentation look somewhat contradictory for me. What is the cause of the error?

 

Nowhere can not find an example of creating extensions using Magento integrations 2, although it seems very simple. I have to look for information in small pieces.

 

I would really appreciate any help!
Thank you.

 

1 REPLY
Highlighted
Moderator

Re: Integration as Marketplace Extension issue (Extension submit and "no matching package found

Hi @vladusp,

 

It seems you are trying to use the worng module version.
For example, you could use something like:

 

"require": {
    "php": "~5.5.0|~5.6.0|~7.0.0",
    "magento/framework": "100.1.*",
    "magento/module-integration": "100.1.*"
},

I guess you're working with Magento 2.1.x.

Take a look to Magento's modules compose.json file to check which version of the module you could or should require.

--
If the answer is useful, please give "Kudos" or "Accept as Solution".