cancel
Showing results for 
Search instead for 
Did you mean: 

Your extension requires PHP version which is not supported by selected Magento edition

SOLVED

Your extension requires PHP version which is not supported by selected Magento edition

I'm trying to release my extension.

In 'Extension Details' I upload my zip package (in my composer.json file I have

"php": "~5.5.0|~5.6.0|~7.0.0"

) and choose Community Edition 2.1

When I click on submit button I receive this error message: "Your extension requires PHP version (~5.5.0|~5.6.0|~7.0.0) which is not supported by selected Magento edition".

 

Yesterday I uploaded an extension with the same required package in composer.json file 

"php": "~5.5.0|~5.6.0|~7.0.0"

and all worked fine.

 

What is going on?

--
Problema risolto? Clicca Accept as Solution!

My Magento Marketplace page
11 REPLIES

Re: Your extension requires PHP version which is not supported by selected Magento edition

We add this into composer.json file but there reflect error as
'Your extension requires PHP version (~5.6.0|7.0.2|~7.0.6) which is not supported by selected Magento edition.'


"require": {
"php": "~5.6.0|7.0.2|~7.0.6"
},
How to solve this.

Re: Your extension requires PHP version which is not supported by selected Magento edition

find any solution?

Re: Your extension requires PHP version which is not supported by selected Magento edition

Magento 2.1.x supports PHP starting from 5.6 version. In the requirement you have in composer.json PHP version starts from 5.5. It will be good to update your module's minimum version to be 5.6.

 

"php": "~5.6.5|7.0.2|7.0.4|~7.0.6",

Hope it helps. 

Re: Your extension requires PHP version which is not supported by selected Magento edition

Still same error. Any updates ?

 

Re: Your extension requires PHP version which is not supported by selected Magento edition

Can you please share full content of your composer.json file?

Re: Your extension requires PHP version which is not supported by selected Magento edition

Now it's working fine, we have to update PHP version like

 

"php": "~5.6.5|7.0.2|7.0.6|~7.0.6"

 

Re: Your extension requires PHP version which is not supported by selected Magento edition

Thank you Max.

 

It solved my issue.

--
Problema risolto? Clicca Accept as Solution!

My Magento Marketplace page

Re: Your extension requires PHP version which is not supported by selected Magento edition

Answer from Magento:

 

The following is a short-term solution to the issue and should be implemented in the compsore.json file:
 
Extensions for Magento 2.0 or Magento 2.1 only:
 

M 2.0  —> "~5.5.22|~5.6.0|7.0.2|~7.0.6”

M 2.1  —> "~5.6.5|7.0.2|7.0.4|~7.0.6”

 

Extensions for Magento 2.0 and Magento 2.1 (supports both versions):

 

M 2.0 and 2.1 —> "~5.5.22|~5.6.0|7.0.2|7.0.4|~7.0.6"

Re: Your extension requires PHP version which is not supported by selected Magento edition

I'm facing the same issue. This last solution still does not work for me.

(For M2.0, 2.1)

Error:

 

Your extension requires PHP version (~5.5.22|~5.6.0|7.0.2|7.0.4|~7.0.6) which is not supported by selected Magento edition.