cancel
Showing results for 
Search instead for 
Did you mean: 

CMS static blocks image problem

SOLVED

CMS static blocks image problem

I'm having problems with image upload and deletion when editing CMS Statics blocks.

Almost half of the time I get kicked back to Admin login page when I try to upload or delete images and sometimes when switching to another folder.

Just before being redirected I receive following responce:
{"ajaxExpired":1,"ajaxRedirect":"http:\/\/www.example.com\/admin\/index\/login\/key\/################################\/"}

 

This happens way too fast to be caused by timeout. I have tried clearing caches and disabling secret key, but with no luck.

 

There is also this error in the magento reports folder, but I'm unsure if it's related to this problem:
a:5:{i:0;s:45:"Unable to read response, or response is empty";i:1;s:847:"#0 /var/www/lib/Varien/Http/Client.php(61): Zend_Http_Client->request('GET')
#1 /var/www/app/code/core/Mage/Adminhtml/controllers/DashboardController.php(100): Varien_Http_Client->request('GET')
#2 /var/www/app/code/core/Mage/Core/Controller/Varien/Action.php(418): Mage_Adminhtml_DashboardController->tunnelAction()
#3 /var/www/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(250): Mage_Core_Controller_Varien_Action->dispatch('tunnel')
#4 /var/www/app/code/core/Mage/Core/Controller/Varien/Front.php(172): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#5 /var/www/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
#6 /var/www/app/Mage.php(684): Mage_Core_Model_App->run(Array)
#7 /var/www/index.php(87): Mage::run('default', 'store')
#8 {main}";s:3:"url";s:522:"/index.php/admin/dashboard/tunnel/key/################################/?ga=################################";s:11:"script_name";s:10:"/index.php";s:4:"skin";s:5:"admin";}

5 REPLIES

Re: CMS static blocks image problem

We're getting the same error message in var/report.

Have you been able to tackle this issue?

Re: CMS static blocks image problem

It seems that the Dashboard page tries to call this Image Chart Google API and does not get response in time. There  seems to be the timeout 5 seconds.

 

The URL as is in Magento class Mage_Adminhtml_Block_Dashboard_Graph: const API_URL = 'http://chart.apis.google.com/chart';

 

More info: https://developers.google.com/chart/image/

 

Regards, Tomas

Re: CMS static blocks image problem

I have the same problem since I installed security patchs.

 

Thanks for your reply dermo666, but i don't understand how to fix it ?

I have Magento 1.7.0.2.

 

Do we need a special server requirement ?

 

Thanks in advance

Re: CMS static blocks image problem

Changing from memcache to filesystemcache fixed this problem for us.

Re: CMS static blocks image problem

Hello,

 

I have a problem that the sliders on the home page are not displaying.  I have 2 block side by side. The block to the left disappeared from the front end and the block from the right slid to the left.

 

My site is http://www.microdont.net/

 

The diamond burs block used to be on the right side and a different block with sliding images was on the left. Both blocks are enabled in the back end. Thank you!