cancel
Showing results for 
Search instead for 
Did you mean: 

Problème après Installation

SOLVED

Problème après Installation

Bonjour,
 
J'ai un problème de super débutant, je travaille en local avec MAMP:
J'ai installé sans problème la version Magento-CE-2.2.2-2017
 
Quand je me rends à cette adresse http: // localhost: 8888 /, j'arrive bien sur la HOMEPAGE, il y a juste une ligne de texte:CMS homepage content goes here.. Oui, je n'ai pas encore de thème installé.
 

test.jpeg

 En fait, j'aimerais me connecter à l'admin, mais peu importe le lien auquel j'essaie d'accéder, j'ai une erreur 404.
 
Ex: je clique sur créer un compte ci-dessus à droite, et l'URL http://localhost:8888/customer/account/create/ mène à une erreur 404.
 
Je comprends que le chemin n'est pas bon, mais je ne sais pas vraiment comment le rectifier.
 
Merci pour les informations.

4 REPLIES

Re: Problème après Installation

You need to keep index.php after your local domain name.

Try with below link,
http://localhost: 8888/index.php/ customer/account/create

You need to enable url_rewrite php mode to solve your 404 problems.

Clear cache and check.
If Issue Solved, Click Kudos/Accept As solutions.

Re: Problème après Installation

Hi Rakesh, thanks Smiley Happy

 

My index.php

<?php
/**
* Application entry point
*
* Example - run a particular store or website:
* --------------------------------------------
* require __DIR__ . '/app/bootstrap.php';
* $params = $_SERVER;
* $params[\Magento\Store\Model\StoreManager:Smiley TongueARAM_RUN_CODE] = 'website2';
* $params[\Magento\Store\Model\StoreManager:Smiley TongueARAM_RUN_TYPE] = 'website';
* $bootstrap = \Magento\Framework\App\Bootstrap::create(BP, $params);
* \/** @var \Magento\Framework\App\Http $app *\/
* $app = $bootstrap->createApplication(\Magento\Framework\App\Http::class);
* $bootstrap->run($app);
* --------------------------------------------
*
* Copyright © Magento, Inc. All rights reserved.
* See COPYING.txt for license details.
*/

try {
require __DIR__ . '/app/bootstrap.php';
} catch (\Exception $e) {
echo <<<HTML
<div style="font:12px/1.35em arial, helvetica, sans-serif;">
<div style="margin:0 0 25px 0; border-bottom:1px solid #ccc;">
<h3 style="margin:0;font-size:1.7em;font-weight:normal;text-transform:none;text-align:left;color:#2f2f2f;">
Autoload error</h3>
</div>
<p>{$e->getMessage()}</p>
</div>
HTML;
exit(1);
}

$bootstrap = \Magento\Framework\App\Bootstrap::create(BP, $_SERVER);
/** @var \Magento\Framework\App\Http $app */
$app = $bootstrap->createApplication(\Magento\Framework\App\Http::class);
$bootstrap->run($app);

 

I don't see URL rewrite in this file...

Re: Problème après Installation

Its a php mod you cant find it inside index.php file.

 

Youhttps://www.digitalocean.com/community/tutorials/how-to-rewrite-urls-with-mod_rewrite-for-apache-on-... can follow below link for more details,

 

If Issue Solved, Click Kudos/Accept As solutions.

Re: Problème après Installation

Hi Rakesh, thanks for your reply.

 

I found my problem, I did not copy the hidden files after the extract.
I downloaded the software Invisibles (mac) and then I copied the right files to the right place after another installation

 

It's ok form me.

 

Smiley Happy