cancel
Showing results for 
Search instead for 
Did you mean: 

API Problem nach Einrichtung von Multistore

API Problem nach Einrichtung von Multistore


Der Shop läuft allerdings komme ich nicht drumherum die index.php zu ändern - erst dann läuft der Multishop.
Folgendes habe ich dort ergänzt:

switch($_SERVER['HTTP_HOST']) {
case 'domain1.de':
$mageRunCode = isset($_SERVER['MAGE_RUN_CODE']) ? $_SERVER['MAGE_RUN_CODE'] : 'shopcode';
$mageRunType = isset($_SERVER['MAGE_RUN_TYPE']) ? $_SERVER['MAGE_RUN_TYPE'] : 'website';
break;
case 'domain2.de':
$mageRunCode = isset($_SERVER['MAGE_RUN_CODE']) ? $_SERVER['MAGE_RUN_CODE'] : neueshopcode´;
$mageRunType = isset($_SERVER['MAGE_RUN_TYPE']) ? $_SERVER['MAGE_RUN_TYPE'] : 'website';
break;
}

Allerdings habe ich nun ein anderes Problem.
Ich habe eine Schnittstelle zu einer Lagerwirtschaft - diese ist via API mit dem Shop verbunden - leider connected dieser nicht mehr.
Nachfruf der URL http://meineurl.de/index.php/api/xmlrpc - bekomme ich folgenden Fehler:
<?xml version="1.0" encoding="UTF-8"?>

-<methodResponse>


-<fault>


-<value>


-<struct>


-<member>

<name>faultCode</name>


-<value>

<int>630</int>

</value>

</member>


-<member>

<name>faultString</name>


-<value>

<string>Unable to read request</string>

</value>

</member>

</struct>

</value>

</fault>

</methodResponse>
Weiß jemand wie ich das gerade biegen kann? Die Lagerwirtschaft wird dringend benötigt - andernfalls kann ich keinen Multistore nebenbei laufen haben.


Besten Dank bis hierhin!
Add Comment
Accept as Solution
Kudo 0
1 REPLY

Re: API Problem nach Einrichtung von Multistore

Niemand??