cancel
Showing results for 
Search instead for 
Did you mean: 

Frameworkproblem Version 2.2.4

Frameworkproblem Version 2.2.4

Hallo zusammen,

ich habe über meinen Anbieter ein Image mit Magento 2.2.3 auf einem Server installiert. Es läuft auch, soweit ich es überblicken kann. Das System bot mir direkt ein Update auf 2.2.4 an, welches ich ausgeführt habe.

Nun wollte ich ein deutsches Sprachpaket installieren. Dies habe ich im "Extension Manager" fertig zur Installation "gefunden".

Beim Check vor der Installation kommt diese Meldung:

Problem 1
- splendidinternet/mage2-locale-de-de 1.13.0 requires magento/framework ^100.0.0 -> satisfiable by magento/framework[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.1.0, 100.0.10, 100.0.11, 100.1.1, 100.0.12, 100.1.2, 100.1.3, 100.0.13, 100.1.4, 100.0.14, 100.1.5, 100.0.15, 100.1.6, 100.1.7, 100.0.16, 100.0.17, 100.1.8, 100.1.9, 100.0.18, 100.0.19, 100.1.10, 100.1.11, 100.0.20, 100.1.12, 100.1.13].
- splendidinternet/mage2-locale-de-de 1.13.0 requires magento/framework ^100.0.0 -> satisfiable by magento/framework[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.1.0, 100.0.10, 100.0.11, 100.1.1, 100.0.12, 100.1.2, 100.1.3, 100.0.13, 100.1.4, 100.0.14, 100.1.5, 100.0.15, 100.1.6, 100.1.7, 100.0.16, 100.0.17, 100.1.8, 100.1.9, 100.0.18, 100.0.19, 100.1.10, 100.1.11, 100.0.20, 100.1.12, 100.1.13].
- Can only install one of: magento/framework[101.0.4, 100.0.2].
- Can only install one of: magento/framework[101.0.4, 100.0.3].
- Can only install one of: magento/framework[101.0.4, 100.0.4].
- Can only install one of: magento/framework[101.0.4, 100.0.5].
- Can only install one of: magento/framework[101.0.4, 100.0.6].
- Can only install one of: magento/framework[101.0.4, 100.0.7].
- Can only install one of: magento/framework[101.0.4, 100.0.8].
- Can only install one of: magento/framework[101.0.4, 100.0.9].
- Can only install one of: magento/framework[101.0.4, 100.1.0].
- Can only install one of: magento/framework[101.0.4, 100.0.10].
- Can only install one of: magento/framework[101.0.4, 100.0.11].
- Can only install one of: magento/framework[101.0.4, 100.1.1].
- Can only install one of: magento/framework[101.0.4, 100.0.12].
- Can only install one of: magento/framework[101.0.4, 100.1.2].
- Can only install one of: magento/framework[101.0.4, 100.1.3].
- Can only install one of: magento/framework[101.0.4, 100.0.13].
- Can only install one of: magento/framework[101.0.4, 100.1.4].
- Can only install one of: magento/framework[101.0.4, 100.0.14].
- Can only install one of: magento/framework[101.0.4, 100.1.5].
- Can only install one of: magento/framework[101.0.4, 100.0.15].
- Can only install one of: magento/framework[101.0.4, 100.1.6].
- Can only install one of: magento/framework[101.0.4, 100.1.7].
- Can only install one of: magento/framework[101.0.4, 100.0.16].
- Can only install one of: magento/framework[101.0.4, 100.0.17].
- Can only install one of: magento/framework[101.0.4, 100.1.8].
- Can only install one of: magento/framework[101.0.4, 100.1.9].
- Can only install one of: magento/framework[101.0.4, 100.0.18].
- Can only install one of: magento/framework[101.0.4, 100.0.19].
- Can only install one of: magento/framework[101.0.4, 100.1.10].
- Can only install one of: magento/framework[101.0.4, 100.1.11].
- Can only install one of: magento/framework[101.0.4, 100.0.20].
- Can only install one of: magento/framework[101.0.4, 100.1.12].
- Can only install one of: magento/framework[101.0.4, 100.1.13].
- magento/product-community-edition 2.2.4 requires magento/framework 101.0.4 -> satisfiable by magento/framework[101.0.4].
- Installation request for magento/product-community-edition 2.2.4 -> satisfiable by magento/product-community-edition[2.2.4].
- Installation request for splendidinternet/mage2-locale-de-de 1.13.0 -> satisfiable by splendidinternet/mage2-locale-de-de[1.13.0].

For additional assistance, see component dependency help .

Dank Google weiß ich dass ich nicht der erste bin der auf dieses Problem stößt. Aber eine Lösung steht leider nirgend wo dabei. Dieses Problem ist auch nicht auf das Sprachpaket beschränkt, egal welche der möglichen 21 Erweiterungen ich zu installieren versuche, immer scheitert es daran.

Ich bin für jeden Rat dankbar ... Smiley Happy

2 REPLIES

Re: Frameworkproblem Version 2.2.4

Hello @daniel_hahn

 

can you please share your composer.json code.

Re: Frameworkproblem Version 2.2.4

Hello @Sunil Patel

did you mean this:

{
"name": "magento/project-community-edition",
"description": "eCommerce Platform for Growth (Community Edition)",
"type": "project",
"version": "2.2.3",
"license": [
"OSL-3.0",
"AFL-3.0"
],
"require": {
"magento/product-community-edition": "2.2.4",
"composer/composer": "@alpha"
},
"require-dev": {
"phpunit/phpunit": "~6.2.0",
"squizlabs/php_codesniffer": "3.2.2",
"phpmd/phpmd": "@stable",
"pdepend/pdepend": "2.5.2",
"friendsofphp/php-cs-fixer": "~2.2.0",
"lusitanian/oauth": "~0.8.10",
"sebastian/phpcpd": "2.0.4"
},
"autoload": {
"psr-4": {
"Magento\\Framework\\": "lib/internal/Magento/Framework/",
"Magento\\Setup\\": "setup/src/Magento/Setup/",
"Magento\\": "app/code/Magento/"
},
"psr-0": {
"": [
"app/code/"
]
},
"files": [
"app/etc/NonComposerComponentRegistration.php"
],
"exclude-from-classmap": [
"**/dev/**",
"**/update/**",
"**/Test/**"
]
},
"autoload-dev": {
"psr-4": {
"Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
"Magento\\Tools\\": "dev/tools/Magento/Tools/",
"Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
"Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
"Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
}
},
"minimum-stability": "stable",
"repositories": [
{
"type": "composer",
"url": "https://repo.magento.com/"
}
],
"extra": {
"magento-force": "override"
}
}