cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 1.9 jquery Problem

Magento 1.9 jquery Problem

Hallo Gemeinde,

in dem von mir übernommenen Magento 1.9.1.0 ist die jquery-Version veraltet.

Ich habe einige Probleme mit den Vorbelegungen von Formularen (u.a. Onestepcheckout). Diese erfolgen teilweise mittels AJAX-Requests.

Auch beim Ausfüllen von Formularen kommt es dazu, dass das Einblenden der Versandbestätigung erst beim zweiten Ausfüllen des Formulars erscheint (Formular wird trotzdem bei jedem Ausfüllen versendet, nur erscheint beim ersten Mal keine Bestätigung).

 

Die in Magento enthaltene jquery-Version 1.10.2 ist veraltet und weisst Funktionen auf, die teilweise veraltet oder nicht mehr existent sind.

Daher vermute ich, dass meine Formularprobleme ggf. mit der alten Version zu tun haben.

 

Mein Frage daher: Wie ist eure Meinung, kann es die Ursache sein? Und wenn JA, kann man die Version einfach austauschen und wenn JA, wie?

 

Ist es mit dem einfachen Austausch per Copy/Paste getan und dem Ersetzen der Versionsnummer in den XML-Dateien, oder greift das Ganze tiefer?

 

1 REPLY

Re: Magento 1.9 jquery Problem

Das kommt ganz darauf an, pauschal ist das gar nicht so einfach zu sagen.

Installiere dir mal ein Tool wie zb Firebug und dann schau dir mal die Fehler an.

Denn wenn es ab und an funktinioniert liegt der Fehler vielleicht doch irgendwo anders. Mit Firebug kannst du auch temporär mal eine andere jquery Version einbinden und dir anschauen ob das besser läuft. Die Fehler müssen aber trotzdem bereinigt werden.