cancel
Showing results for 
Search instead for 
Did you mean: 

Magento APIs in XAMPP

Magento APIs in XAMPP

Hey Leute,

 

ich versuche mich gerade ein wenig mit den Magento APIs und talend.

Zu Trainingszwecken möchte ich z.b. meine orders in ein file speichern. 

Als Umgebung hierfür nutze ich die Standard Xampp Installation mit Magento1.9.3.4 + example files. Derzeit halte ich mich an Tutorials und Videos um vorwärts zu kommen.

Da mir die REST API aufgrund der Authentifizierung zu kompliziert aussah, nutze ich zunächst SOAP.

 

Hier zu meinem Problem:

 

Wie in den Dokumentationen beschrieben, nutze ich folgendes Beispiel:

 

<?php
$proxy = new SoapClient('http://127.0.0.1/magento/api/v2_soap/?wsdl'); // TODO : change url
$sessionId = $proxy->login('test', '123456'); // TODO : change login and pwd if necessary

$result = $proxy->salesOrderInfo($sessionId, '200000006');
var_dump($result);
?>  

Den Test Account habe ich im Backend erstellt und auch unter "Role" alle Ressourcen freigegeben und diese dem Account 'test' zugeordnet.

Versuche ich nun aber 'http://127.0.0.1/magento/test/test.php' aufzurufen, erhalte ich nur folgenden Fehler:

 

Fatal error: Uncaught SoapFault exception: [WSDL] SOAP-ERROR: Parsing WSDL: Couldn't load from 'http://127.0.0.1/magento/api/v2_soap/?wsdl' : failed to load external entity "http://127.0.0.1/magento/api/v2_soap/?wsdl" in C:\xampp\htdocs\Magento\test\test.php:2 Stack trace: #0 C:\xampp\htdocs\Magento\test\test.php(2): SoapClient->SoapClient('http://127.0.0....') #1 {main} thrown in C:\xampp\htdocs\Magento\test\test.php on line 2

Eine direkte Abfrage an 

http://127.0.0.1/magento/index.php/api/v2_soap/index/wsdl/1

hingegen funktioniert, weshalb ich davon ausgehe, dass die SOAP dll in PHP funktioniert.

Ich habe auch weitere .dll in der php.ini aktiviert, allerdings ohne Erfolg.

 

Hat jemand eine Ahnung, woran es potentiell noch liegen könnte, bzw. was der Fehlercode überhaupt aussagt?

 

Viele Grüße!

 

 

1 REPLY

Re: Magento APIs in XAMPP

Hi Hans,

 

du müsstest mal versuchen ob du mit curl die wsdl-Datei bekommst. Ansonsten gibt es aber zu dem Thema auch sehr viele Hinweise bei Google. Ich vermute mal das die .wsdl nicht geladen werden kann und deshalb der Soap-Call nicht funkt.

 

Grüße Björn