cancel
Showing results for 
Search instead for 
Did you mean: 

Menüpunkt hinzufügen funktioniert nicht - leere Seite im Backend!

SOLVED

Menüpunkt hinzufügen funktioniert nicht - leere Seite im Backend!

Ich versuche gerade nach der Anleitung aus dem Galileo Buch (Magento - das umfassende Handbuch, Auflage 2), eine eigene Extension zu erstellen. Diese soll erstmal nur einen neuen Menüpunkt im Backend hinzufügen.

 

temp.pngMenüpunkt "branch" soll hinzugefügt werden.Leider scheint das Tutorial veraltet zu sein und nicht mehr zu funktionieren. Ich verwende Magento 1.8.1, ich weiß leider nicht für welche Magento Version das Tutorial geschrieben wurde.


Hier sind alle meine Dateien:

 

app/etc/modules/Galileo_Branches.html:

 

<?xml version="1.0" encoding="UTF-8"?>
<config>
<modules>
<Galileo_Branches>
<active>true</active>
<codePool>community</codePool>
<depends>
<Mage_Core />
<Mage_Adminhtml />
</depends>
</Galileo_Branches>
</modules>
</config>

 

app/code/community/Galileo/Branches/etc/config.xml:

 

<?xml version="1.0" encoding="UTF-8"?>
<config>
<modules>
<Galileo_Branches>
<version>2018.5.24</version>
</Galileo_Branches>
</modules>
<global>
<blocks>
<branches>
<class>Galileo_Branches_Block</class>
</branches>
</blocks>
<helpers>
<branches>Galileo_Branches_Helper</branches>
</helpers>
<models>
<branches>Galileo_Branches_Model</branches>
</models>
</global>
<frontend>
<routers>
<branches>
<use>standard</use>
<args>
<module>Galileo_Branches</module>
<frontName>branches</frontName>
</args>
</branches>
</routers>
</frontend>
<admin>
<routers>
<branches>
<use>admin</use>
<args>
<module>Galileo_Branches</module>
<frontName>branches</frontName>
</args>
</branches>
</routers>
</admin>
</config>

 

app/code/community/Galileo/Branches/etc/adminhtml.xml:

 

<?xml version="1.0" encoding="UTF-8"?>
<config>
    <menu>
        <branches translate="title" module="branches">
            <title>Branches</title>
            <sort_order>2000</sort_order>
            <children>
                <list translate="title" module="branches">
                    <title>List</title>
                    <action>branches/adminhtml_branches</action>
                    <sort_order>10</sort_order>
                </list>
            </children>
        </branches>
    </menu>
    <acl>
        <resources>
            <admin>
                <children>
                    <branches>
                        <title>Branches</title>
                        <sort_order>2000</sort_order>
                    </branches>
                    <children>
                        <list translate="title">
                            <title>List</title>
                            <sort_order>10</sort_order>
                        </list>
                    </children>
                </children>
            </admin>
        </resources>
    </acl>
</config>

Helper: app/code/community/Galileo/Branches/Helper/Data.php:

 

<?php
class Galileo_Branches_Helper_Data extends Mage_Core_Helper_Abstract
{

}

Controller app/code/community/Galileo/controllers/Adminhtml/BranchesController.php:

 

<?php

class Galileo_Branches_Adminhtml_BranchesController extends Mage_Adminhtml_Controller_Action
{
/*
* Die indexAction() entspricht der Standardmethode eines Controllers,
* die immer dann aufgerufen wird, wenn keine andere "Action" explizit angegeben wird.
*/
public function indexAction()
{
/*
* In der indexAction() laden wir das Layout mit $this->loadLayout() und lassen es anschließend von Magento mit $this->renderLayout() rendern.
*/
$this->loadLayout();
$this->renderLayout();
}
}

 

Hier ist das Resultat:

 

temp.pngResult

Habe ich etwas falsch gemacht oder ist der Code einfach nicht für Magento 1.8.1 geeignet?

1 REPLY

Re: Menüpunkt hinzufügen funktioniert nicht - leere Seite im Backend!

Es war mein Fehler... In der Datei app/code/community/Galileo/Branches/etc/config.xml haben für "Helper" und "Models" die Blöcke für "<class>" gefehlt.

 

Lösung:

<?xml version="1.0" encoding="UTF-8"?>
<config>
<modules>
<Galileo_Branches>
<version>0.1.0</version>
</Galileo_Branches>
</modules>
<global>
<blocks>
<branches>
<class>Galileo_Branches_Block</class>
</branches>
</blocks>
<helpers>
<branches>
<class>Galileo_Branches_Helper</class>
</branches>
</helpers>
<models>
<branches>
<class>Galileo_Branches_Model</class>
</branches>
</models>
</global>
<frontend>
<routers>
<branches>
<use>standard</use>
<args>
<module>Galileo_Branches</module>
<frontName>branches</frontName>
</args>
</branches>
</routers>
</frontend>
<admin>
<routers>
<branches>
<use>admin</use>
<args>
<module>Galileo_Branches</module>
<frontName>branches</frontName>
</args>
</branches>
</routers>
</admin>
</config>