cancel
Showing results for 
Search instead for 
Did you mean: 

Parameter geht bei Weiterleitung verloren

Parameter geht bei Weiterleitung verloren

Hallo,

 

für den Online-Shop www.fotoadvent.de habe ich eine Google AdWords Werbekampagne erstellt. Klickt jemand auf die Werbeanzeigen, so wird er auf www.fotoadvent.de verlinkt. Damit ich weiß das ein Besucher ausgehend von einem Klick auf eine AdWords-Anzeige gekauft hat wird der URL der sogenannte gclid-Parameter angehangen.

 

Hier weitere Infos zum gclid-Parameter:

 

https://support.google.com/analytics/answer/2938246?hl=de

 

Dummerweise erfolgt von www.fotoadvent.de eine Weiterleitung zu fotoadvent.de. Das führt dazu das der glicd-Parameter verloren geht. Aus diesem Grund funktioniert das Tracking nicht korrekt. Ich möchte nun die .htaccess-Datei so anpassen, dass der gclid-Parameter bei der Weiterleitung von von www.fotoadvent.de auf fotoadvent.de nichtmehr verloren geht. Leider kenne ich mich mit regulären Ausdrücken nicht besonders gut aus und habe was die .htaccess-Datei angeht reletiv wenig Erfahrung.

 

Aus diesem Grund die Frage an Euch was ich in folgender .htaccess-Datei anpassen muss, damit die URL Parameter bei der Weiterleitung von www.fotoadvent.de zu fotoadvent.de nicht verloren gehen.

 

 

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

#    Action php5-cgi /cgi-bin/php5-cgi
#    AddHandler php5-cgi .php

############################################
## GoDaddy specific options

#   Options -MultiViews

## you might also need to add this line to php.ini
##     cgi.fix_pathinfo = 1
## if it still doesn't work, rename php.ini to php5.ini

############################################
## this line is specific for 1and1 hosting

    #AddType x-mapp-php5 .php
    #AddHandler x-mapp-php5 .php

############################################
## default index file

    DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

#    php_value memory_limit 64M
    php_value memory_limit 256M
    php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

    php_flag magic_quotes_gpc off

############################################
## disable automatic session start
## before autoload was initialized

    php_flag session.auto_start off

############################################
## enable resulting html compression

    #php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

    php_flag suhosin.session.cryptua off

###########################################
# turn off compatibility with PHP4 when dealing with objects

    php_flag zend.ze1_compatibility_mode Off

</IfModule>

<IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

    SecFilterEngine Off
    SecFilterScanPOST Off
</IfModule>

<IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

    # Insert filter on all content
    ###SetOutputFilter DEFLATE
    # Insert filter on selected content types only
    #AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript

    # Netscape 4.x has some problems...
    #BrowserMatch ^Mozilla/4 gzip-only-text/html

    # Netscape 4.06-4.08 have some more problems
    #BrowserMatch ^Mozilla/4\.0[678] no-gzip

    # MSIE masquerades as Netscape, but it is fine
    #BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

    # Don't compress images
    #SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

    # Make sure proxies don't deliver the wrong content
    #Header append Vary User-Agent env=!dont-vary

</IfModule>

<IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

    SSLOptions StdEnvVars

</IfModule>

<IfModule mod_rewrite.c>

############################################
## enable rewrites

    Options +FollowSymLinks
    RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

    #RewriteBase /magento/

############################################
## uncomment next line to enable light API calls processing

#    RewriteRule ^api/([a-z][0-9a-z_]+)/?$ api.php?type=$1 [QSA,L]

############################################
## rewrite API2 calls to api.php (by now it is REST only)

    RewriteRule ^api/rest api.php?type=rest [QSA,L]

############################################
## workaround for HTTP authorization
## in CGI environment

    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## TRACE and TRACK HTTP methods disabled to prevent XSS attacks

    RewriteCond %{REQUEST_METHOD} ^TRAC[EK]
    RewriteRule .* - [L,R=405]

############################################
## redirect for mobile user agents

    #RewriteCond %{REQUEST_URI} !^/mobiledirectoryhere/.*$
    #RewriteCond %{HTTP_USER_AGENT} "android|blackberry|ipad|iphone|ipod|iemobile|opera mobile|palmos|webos|googlebot-mobile" [NC]
    #RewriteRule ^(.*)$ /mobiledirectoryhere/ [L,R=302]

############################################
## always send 404 on missing files in these folders

    RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

    RewriteRule .* index.php [L]

</IfModule>


############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

    AddDefaultCharset Off
    #AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

    ExpiresDefault "access plus 1 year"

</IfModule>

############################################
## By default allow all access

    Order allow,deny
    Allow from all

###########################################
## Deny access to release notes to prevent disclosure of the installed Magento version

    <Files RELEASE_NOTES.txt>
        order allow,deny
        deny from all
    </Files>

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

    #FileETag none
3 REPLIES

Re: Parameter geht bei Weiterleitung verloren

Hallo,

 

die Weiterleitung findet aber momentan nicht in der .htaccess statt sondern ich vermute mal stark von Magento.

Haben Sie als "base_url" die URL http://fotoadvent.de eingetragen und die Option "weiterleitung zur Basisurl" auf ja?

 

Warum leiten Sie die Adwords - Anzeige nicht direkt zu http://fotoadvent.de ?

 

Die .htaccess Regel müsste so ähnlich aussehen: BITTE VORHER TESTEN

 

RewriteEngine on
RewriteCond %{QUERY_STRING} gclid=123456
RewriteCond %{HTTP_HOST} ^www\.fotoadvent\.de$ [NC]
RewriteRule ^(.*)$ http://fotoadvent\.de/$1 [L,R=301]

 

 

Beste Grüße | Regards, Roman from CopeX.io

Re: Parameter geht bei Weiterleitung verloren

Hallo,

 

Sie Schreiben "die Weiterleitung findet aber momentan nicht in der .htaccess statt sondern ich vermute mal stark von Magento.".

 

Wenn die Weiterleitung nicht per .htaccess-Datei stattfindet, sondern stattdessen über das Magento-Backend wäre meine Frage, ob ich im Backend irgendeine Einstellung machen kann die dafür sorgt das URL-Parameter nicht verlorgen gehen?

 

 

Re: Parameter geht bei Weiterleitung verloren

Eigentlich sollte die Weiterleitung von Magento auch inkl. aller in der URL übergebenen Parameter "out of the box" funktionieren.

Vielleicht ist ja die Serverkonfig der Übeltäter ?

Beste Grüße | Regards, Roman from CopeX.io