cancel
Showing results for 
Search instead for 
Did you mean: 

Probleme mit security Patches SUPEE-5344 and SUPEE-1533

SOLVED

Probleme mit security Patches SUPEE-5344 and SUPEE-1533

Hallo, ich habe probleme mit der Installation der Patches SUPEE-5344 and SUPEE-1533

 

Nach dem Befehlr über Winscp bekomme ich diese Information:

 

Error! Some required system tools, that are utilized in this sh script, are not installed:
Tool(s) "patch" is(are) missed, please install it(them).

 

Kann mir vielleicht Jemand einen Tipp oder Hilfe geben?

 

Vielen Dank und Grüße

8 REPLIES

Re: Probleme mit security Patches SUPEE-5344 and SUPEE-1533

Hallo,

 

auf dem Server muß "patch" installiert sein, sonst können die Patches  nicht automatisiert angewendet werden. Unter Debian/Ubuntu sollte ein "apt-get install patch" reichen. Wenn du keinen Zugriff auf den Server selbst hast, dann beim Hoster anfragen oder die Patches "zu Fuß" einspielen. Das erfordert allerdings etwas Programmierwissen.

 

Alternativ können die Patches auch lokal auf nem VPS o.ä. eingespielt und die geänderten Dateien hoch geladen werden. Auch dafür ist aber etwas Hintergrundwissen erforderlich.

 

Beste Grüße,

Ingo

Re: Probleme mit security Patches SUPEE-5344 and SUPEE-1533

Hallo Ingo,

 

vielen Dank für deine Nachricht.

 

Hört sich für mich alles schwarz an ;-)

Bin kein Profi aber versuche mich durchzukämpfen.

 

Wo sehe ich ob ein patch installiert ist oder wie kann ich diesen installieren?

Was ist apt-get install patch? Wie bekomme ich den auf dem Server? Selber?

 

Danke für deine Mühe.

Viele Grüße

Re: Probleme mit security Patches SUPEE-5344 and SUPEE-1533

hallo,

apt-get install patch ist ein commando für die kommandozeile.

 

ob der patch korrekt installiert kannst du hier prüfen:

https://shoplift.byte.nl/

 

Wenn du es wirklich nicht hinbekommst kann ich dir helfen. schreib mir einfach ne pm 

Mit freundlichen Grüßen, Sebastian Keutmeier

Re: Probleme mit security Patches SUPEE-5344 and SUPEE-1533

Ich habe es zwar geschafft diese beiden Patches erfolgreich zu installieren, wenn ich aber pruefe ob der Shop sicher ist bekomme ich immer noch die Meldung:

WARNING The Magento shop at www.xxx is VULNERABLE to the Shoplift bug. You should fix it ASAP.

 

Ich habe schon mehrfach alle Cache geloescht und alles neu kompliert.

Leider kann mir auch mein host nicht weiterhelfen. Es waere toll, wenn mir jemand einen Tipp geben kann, wie ich hier weiterkomme!

 

Danke schon mal!

IKDR

Re: Probleme mit security Patches SUPEE-5344 and SUPEE-1533

Hallo IkdR,

 

ich habe gestern diese Anleitung benutzt:

http://magentary.com/kb/apply-supee-5344-and-supee-1533-without-ssh/

 

Mit der SSH und Putty hat es nicht funktioniert.

 

Jetzt nach der Überprüfung alles soweit gut.

 

Versuches einfach mit dieser Anleitung.

 

Hoffe es klappt.

 

Kurzes Feedback wäre super.

Danke und Grüße

Re: Probleme mit security Patches SUPEE-5344 and SUPEE-1533

benutzen Sie Full page cache?

den dann bitte auch leeren.

 

Auch der opcode-cache von php kann das problem verursachen.

Den bitte auch leeren (Im zweifel einfach apache neustraten, dann wird der automatisch geleert)

Mit freundlichen Grüßen, Sebastian Keutmeier

Re: Probleme mit security Patches SUPEE-5344 and SUPEE-1533

Hallo marcus,

 

danke, genau mit der Anleitung habe ich die Installation geschafft.

Aber mit dem Cache leeren haben ich noch Probleme....

 

Hallo Sebastian Keutmeier,

vielen Dank.

Full Page Cache ist eine Extension, oder? Zur Zeit benutze ich diese nicht. Sollte ich? Ist sie zu empfehlen?

Leider komme ich mit dem opcode cache nicht weiter. Habe schon alles moeglich ueber den PHP File Manager probiert und auch den Webhoster deswegen um Hilfe gebeten. Der meinte nur, dass PHP-FPM auf dem Server nicht aktiv ist, somit opcode cache dann wohl auch nicht...

Ich denke ich muss irgendwie das php neu starten, leider weiss ich aber nicht, wie ich das anstellen soll.

 

Viele Gruesse

Iris KdR

 

 

 

Re: Probleme mit security Patches SUPEE-5344 and SUPEE-1533