cancel
Showing results for 
Search instead for 
Did you mean: 

Welche ist die MAXIMALE PHP Version für Magento 1.4.1.1 bzw. 1.3.2.4

Welche ist die MAXIMALE PHP Version für Magento 1.4.1.1 bzw. 1.3.2.4

Hallo,

ich habe zwei (ur)alte Magento Versionen (1.4.1.1 sowie 1.3.2.4) auf PHP 5.2 zu laufen. Nun hat unser Hoster angekündigt, bald nur noch 5.5 und neuer anzubieten, sodass ich gezwungen bin, Änderungen vorzunehmen. Am liebsten würde ich die Magento Versionen auch einfach so lassen und nur die PHP-Version erhöhen. Jetzt stellt sich aber die Frage, ob die Shop dann noch funktionsfähig sind. Im Netz finde ich immer nur Mindestvoraussetzungen bzw. -anforderungen an PHP, aber niemals die MAXIMALE lauffähige PHP-Version in Abhängigkeit von der Magento-Version. Daher meine Fragen:

 

  1. Wo finde ich eine Kompatibilitätsmatrix "Magento/maximale PHP Version"?
  2. Gibt es eine Rückwärtskompatibilität bei PHP von z.B. 5.5 auf 5.2?
  3. Womit ist zu rechnen, wenn ich serverseitig einfach die PHP-Version von 5.2 auf 5.5 erhöhe?
  4. Wie kann ich die Shops upgraden und macht das überhaupt noch Sinn bzw. ist eine komplette Neuinstallation besser?
  5. Wie könnte so eine Neuinstallation ohne großen Aufwand vollzogen werden: Tools, Scripte, Import/Export etc.?

    Besten Dank schon mal für die Antworten.
Tags (1)
4 REPLIES

Re: Welche ist die MAXIMALE PHP Version für Magento 1.4.1.1 bzw. 1.3.2.4

Pfuh, das wird schwierig.

Abgesehen von der PHP Version gibt es für deine Magento Shops nicht mal die letzten Security Patches (die gibt es nur bis zu Version 1.5 runter).

 

Zu PHP:

Es gibt von Magento auf der Download Page (unter "Release Archive") einen Patch für PHP 5.4. Dieser Patch setzte aber zumindest Magento 1.6 voraus.

Möglicherweise hilft dir dieser Patch weiter um herauszufinden, was du im Core-Code anpassen müsstest.

 

Ich würde dringend zu einem Upgrade beider Shops auf die aktuellste Version (1.9.x) raten.

-----
Anna from E-CONOMIX

Re: Welche ist die MAXIMALE PHP Version für Magento 1.4.1.1 bzw. 1.3.2.4

Hi avoelki,

vielen Dank für deine Infos und Einschätzung. Mir ist bewusst, dass wir nicht lange auf den alten Magento-Versionen laufen können, insbesondere auch aufgrund der Shop-Sicherheit.

Ich muss allerdings eine Interimslösung finden, die nicht gerade viel Aufwand bringt und schnell zu machen ist. Jetzt habe ich testweise einen Klon meiner Magento 1.4.1.1 auf PHP 5.5 laufen. Zu meinem Erstaunen muss ich sagen, dass es bisher einwandfrei funktioniert.

Gibt es hierfür vielleicht einen umfassenden Test, welcher mir die vollständige Kompatibilitässicherheit geben würde?

Ansonsten probiere ich das mit dem Klon jetzt auf für die Version 1.3.2.4. und poste hier die Ergebnisse.

Besten Dank für den bisherigen Austausch.

Re: Welche ist die MAXIMALE PHP Version für Magento 1.4.1.1 bzw. 1.3.2.4

Hallo,

 

In diesem Fall würde ich es mit PHP CodeSniffer und dem PHP Compatibility tool probieren und das mal über deinen aktuellen Code laufen lassen:

 

Immerhin kommt es ja auch auf deine Magento Module und deren Kompatibilität zu PHP 5.5/5.6 an.

 

Konkrete Änderungen zwischen den PHP Versionen kann man hier nachlesen:

 

Dieser Thread zu iconv_set_encoding im system.log und Zend Framework ist vermutlich auch interessant für dich: http://magento.stackexchange.com/questions/34015/magento-1-9-php-5-6-use-of-iconv-internal-encoding-...

 

 

 

-----
Anna from E-CONOMIX

Re: Welche ist die MAXIMALE PHP Version für Magento 1.4.1.1 bzw. 1.3.2.4

Kurzer Zwischenstand: Magento 1.3.2.4 geht dann leider nicht mehr unter PHP 5.5.

 

Naja, wäre auch zu schön gewesen. Es ist schon ein Wunder, dass überhaut Magento 1.4.1.1 unter PHP 5.5 läuft.