cancel
Showing results for 
Search instead for 
Did you mean: 

"Neu" Label aktivieren

"Neu" Label aktivieren

Hallo! Brauche Hilfe, komme einfach nicht mehr weiter. Hätte gerne, dass Produkte die ich im Backend als Neu gekennzeichnet habe (bzw. bei "news_from_date" "news_to_date" ein Datum eingegeben habe) im Frontend mit einem Label/Marker/Banner versehen werden.

Ich habe es zwar über ein eigenes Attribut geschafft, aber ich hätte gerne die Verknüpfung zu dem Zeitfenster dass ich ohnehin bei einem Produkt eingebe ... Hat Magento da eine Lösung?

2 REPLIES

Re: "Neu" Label aktivieren

Hallo,
öffne die Datei "template/catalog/product/list.phtml" und suche folgenden code: 

<h2 class="product-name"><a href="<?php echo $_product->getProductUrl() ?>" title="<?php echo $_productNameStripped; ?>"><?php echo $_helper->productAttribute($_product, $_product->getName() , 'name'); ?></a>

....

Diesen Code ersetzt Du durch folgenden Code:

<h2 class="product-name">

    <a href="<?php echo $_product->getProductUrl() ?>" title="<?php echo $_productNameStripped; ?>"><?php echo $_helper->productAttribute($_product, $_product->getName() , 'name'); ?></a>  

    <!-- Als NEU kennzeichnen -->
    <?php
        $now = date("Y-m-d H:m:s");
        $newFromDate = Mage::getModel('catalog/product')->load($_product->getID())->getNewsFromDate();
        $newToDate = Mage::getModel('catalog/product')->load($_product->getID())->getNewsToDate();   
                   
        if($newFromDate < $now && $newToDate > $now) { ?>
            <span class="new_product">Neu</span>
        <?php } ?>
    <!-- -->
</h2>
                    
-------- in Deiner css-Datei kannst Du dann darauf zugreifen:
/* Produkt als NEU kennzeichnen */
h2.product-name {position: relative; }
.new_product {
    text-transform: uppercase;
    position: absolute;
    right: 0;

    color: #f00;
    font-size: 16px;
    padding: 18px 0 0 18px;
}

 

Grüße Susanne

Re: "Neu" Label aktivieren

Hallo!

Vielen vielen Dank für den Code. Funktioniert einwandfrei. Melde mich erst jetzt, weil es Probleme damit gab. Hat sich aber herausgestellt, dass es am Cache liegt und nicht am Code ;-)