cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with Host Server? - We can't add this item to your shopping cart right now

Highlighted
New Contributor

Problem with Host Server? - We can't add this item to your shopping cart right now

Hello everybody,  
I am using Mageto 2.1.5. My shop works well with Xampp on Windows 10.

Now I am going to move to my host’s server; php 7.0.14, MySQL 5.6.33
At first I installed a fresh Magento-CE-2.1.5_sample_data-2017-02-20-05-07-23.

It worked, and after I entered my email address in the backend and myself as a customer in the frontend, I ordered something and I got my “Thank you for your order from Main Website Store” by email.

Then I tried my own shop. I got the message: We can't add this item to your shopping cart right now.
I thought that I had a bug in my theme or I introduced another bug elsewhere so I intended to use the perfectly working Luma-installation as a starting point. But today the beloved Luma corporation also refuses accepting orders … Reordering from my customer account the same item as two days before is possible and can be put into the cart. Adding something els: nope.

Another try: I used Magento-CE-2.1.5-2017-02-20-05-04-55 (without sample data) as well. I added my theme and imported my data into the related database. Same result.

The only thing that I can remember is that between March 11 and today I protected the sample shop domain and removed the protection the day after. Consequently you can access it here http://sample-data.shop-microtherm.com/
Try to put something into the cart. Do you see what I see?

Here are some of the latest entries in the debug.log (March 11 and 13) :

[2017-03-11 15:29:42] main.DEBUG: cache_invalidate:  {"method":"POST","url":"http://sample-data.shop-microtherm.com/customer/account/createpost/","invalidateInfo":{"tags":["wish...} []
[2017-03-11 15:30:10] main.DEBUG: cache_invalidate:  {"method":"POST","url":"http://sample-data.shop-microtherm.com/checkout/cart/add/uenc/aHR0cDovL3NhbXBsZS1kYXRhLnNob3AtbWljcm...} []
[2017-03-11 15:32:51] main.DEBUG: cache_invalidate:  {"method":"POST","url":"http://sample-data.shop-microtherm.com/rest/default/V1/carts/mine/payment-information","invalidateIn...} []
[2017-03-13 08:24:43] main.DEBUG: cache_invalidate:  {"method":"POST","url":"http://sample-data.shop-microtherm.com/admin/admin/index/index/key/dd15ba6b6da52197c907646c590765829...} []
[2017-03-13 08:41:29] main.DEBUG: cache_invalidate:  {"method":"POST","url":"http://sample-data.shop-microtherm.com/sales/order/reorder/order_id/3/","invalidateInfo":{"identifie...} []

I tried often, however, there are a lot for March 11 but only three entries on March 13.

I noted that in the file /vendor/magento/zendframework1/library/Zend/Cache/Backend.php 'cache_dir' => null is no more present in 2.1.5
That is, the former hint to replace it with 'cache_dir' => 'var/cache' is no more applicable as a try.

 

Tody I tried "Lima" again. At first, I was able to put something into the cart, but a second item not. When I emptied the cart, I was still not able to put something into the cart.

 

The site is still open for everybody, please try it.

http://sample-data.shop-microtherm.com/

 

Any idea?

  • community-edition
  • magento2
Tags (2)