cancel
Showing results for 
Search instead for 
Did you mean: 

Compilation comand overwrited my modules

Compilation comand overwrited my modules

Hello,

 

I am starting with magento 2 and I need your help. I wanted to install a module but when i ran the upgrade comand I got a message error of compilation so I ran the compilation command but it overwrited my modules and everything I think because website and magento are now down. 

 

I'm so bad. If someone could help me Smiley Happy 

2 REPLIES

Re: Compilation comand overwrited my modules

Can you give screenshot for error/details when you have run compilation command.

 

Run Static content deploy command and then give 777 permission to var folder.

Elsner Technologies

Re: Compilation comand overwrited my modules

I'm getting those errors when I compile (see attached photo). There are more but I can't send you the logs cause I can only send you photos.

 

I tried to update Mageplaza_Blog extension via composer (after selfupdate of composer), the update runs but then when I run the php bin/magento setup:upgrade i'm getting this error: 

Autoload error: Module 'Mageplaza_Blog' from '/home/chiajouw/public_html/app/code/Mageplaza/Blog' has been already defined in '/home/chiajouw/public_html/vendorchiajouw@uk20 [~/public_html]# php bin/magento setup:upgrade

Warning: require(/home/chiajouw/public_html/vendor/composer/../mageplaza/magento-2-blog-extension/registration.php): failed to open stream: No such file or directory in /home/chiajouw/public_html/vendor/composer/autoload_real.php on line 71

Fatal error: require(): Failed opening required '/home/chiajouw/public_html/vendor/composer/../mageplaza/magento-2-blog-extension/registration.php' (include_path='/home/chiajouw/public_html/vendor/magento/zendframework1/library:/home/chiajouw/public_html/vendor/phpunit/php-file-iterator:/home/chiajouw/public_html/vendor/phpunit/phpunit:/home/chiajouw/public_html/vendor/symfony/yaml:.:/usr/local/php56/pear') in /home/chiajouw/public_html/vendor/composer/autoload_real.php on line 71

 

So I think that the developper who was in the company before installed Blog extension via copy/paste in app/code and composer put in /vendor so there is a conflict but I tried to solve this with a tutorial from Mageplaza (it is a well-known error) by deleting Core module from:

  • app/code/Mageplaza/Core
  • vendor/mageplaza/core-m2

But even after, it is not working, I'm still getting the error.

 

logs.png

Tags (2)