cancel
Showing results for 
Search instead for 
Did you mean: 

Help PLZ! Problems with Fooman Speedster: 403 error + Verify Minification ERROR

SOLVED

Help PLZ! Problems with Fooman Speedster: 403 error + Verify Minification ERROR

Hello,
I have a problem with Fooman Speedster
Self-test shows two errors:

1) Verify Permission ERROR (Step 2)
2) Verify Minification ERROR: there are no files starting with "minify_" in "/ opt / bitnami / apps / magento / htdocs / var / minifycache" (Step 3)

 


With regard Verify Permission ERROR (Step 2) - site.com/lib/minify/m.php - 403 Forbidden

I do not find the answers to these errors in the Developer's Guide:
http://cdn.fooman.co.nz/media/custom/upload/UserManual-FoomanSpeedster.pdf
http://cdn.fooman.co.nz/media/custom/upload/TheUltimateGuidetoInstallingMagentoExtensions.pdf
http://store.fooman.co.nz/extensions/magento-extension-speedster.html

Please, any advice and suggestions!

 

Selftest failed with: Step 1 - OK
Verify Permission ERROR (Step 2)
Verify Minification ERROR: there are no files starting with "minify_" in "/opt/bitnami/apps/magento/htdocs/var/minifycache" (Step 3)
Step 4 - OK
Please read the manual for details.
Starting Fooman_Speedster_Model_Selftester
Default store loaded
Magento version: 1.9.0.1
Speedster DB version: Not installed
Speedster Config version: 3.0.14
Checking file locations
Checking rewrites
Checking database
Result: success
Self-test finished

1 REPLY

Re: Help PLZ! Problems with Fooman Speedster: 403 error + Verify Minification ERROR

As per the error message your permissions are not set correctly. From page 8 of the manual:

 

Change your permission settings to allow the file (http://YOURMAGENTOWEBSITE/lib/minify/m.php) to be
executed by the web server. Apply the same setting to the folder /lib/minify and the file m.php.


Note: Permission requirements differ from server to server, but most often permissions 755 or
775 will work. If in doubt, check which permissions are working for your main index.php in the
Magento root folder.