cancel
Showing results for 
Search instead for 
Did you mean: 

Installing eWay extension on Magento CE 2.2.3

SOLVED

Installing eWay extension on Magento CE 2.2.3

I am trying to install eWay extension using composer. I followed their instruction "https://go.eway.io/s/article/How-do-I-install-the-eWAY-Magento-2-extension"

 

After the first step "composer require eway/eway-rapid-magento2 2.0.0" , i have following error

"

./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for eway/eway-rapid-magento2 2.0.0 -> satisfiable by eway/eway-rapid-magento2[2.0.0].
- Conclusion: remove magento/framework 101.0.3
- Conclusion: don't install magento/framework 101.0.3
- eway/eway-rapid-magento2 2.0.0 requires magento/framework 100.1.* -> satisfiable by magento/framework[100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.1.9, 100.1.10, 100.1.11, 100.1.12].
- Can only install one of: magento/framework[101.0.3, 100.1.0].
- Can only install one of: magento/framework[101.0.3, 100.1.1].
- Can only install one of: magento/framework[101.0.3, 100.1.2].
- Can only install one of: magento/framework[101.0.3, 100.1.3].
- Can only install one of: magento/framework[101.0.3, 100.1.4].
- Can only install one of: magento/framework[101.0.3, 100.1.5].
- Can only install one of: magento/framework[101.0.3, 100.1.6].
- Can only install one of: magento/framework[101.0.3, 100.1.7].
- Can only install one of: magento/framework[101.0.3, 100.1.8].
- Can only install one of: magento/framework[101.0.3, 100.1.9].
- Can only install one of: magento/framework[101.0.3, 100.1.10].
- Can only install one of: magento/framework[101.0.3, 100.1.11].
- Can only install one of: magento/framework[101.0.3, 100.1.12].
- Installation request for magento/framework (locked at 101.0.3) -> satisfiable by magento/framework[101.0.3].


Installation failed, reverting ./composer.json to its original content."

 

Any idea how to fix this? Or it is basically eWay's issue?

 

4 REPLIES

Re: Installing eWay extension on Magento CE 2.2.3

Hello ,

It is module problem, seems like that does not support with Magento.

--ignore-platform-reqs while add composer, it will add module but don't know it will work or not.


If it will help you then give us kudoes or accept as solution.

Re: Installing eWay extension on Magento CE 2.2.3

Hi @WZ_OZES

 

I have seen article and command which you are using for install the eway extension - eway-rapid-magento2 2.0.0

 

So as mention in the command , this extension is for Magento 2 version 2.0.0  - The error you are facing because you have latest version of Magento 2.

 

Eway extension is not compatible with your current version of Magento 2 , so you can contact Extension developer and ask them about compatible version of extension , or else new extension which is support magento 2.2.3

 

So at the end - issue is with eway extension packet , no error at magento side.

 

Hope it helps Smiley Happy

if issue solved,Click Kudos & Accept as Solution

Re: Installing eWay extension on Magento CE 2.2.3


@ManthanDavewrote:

Hi @WZ_OZES

 

I have seen article and command which you are using for install the eway extension - eway-rapid-magento2 2.0.0

 

So as mention in the command , this extension is for Magento 2 version 2.0.0  - The error you are facing because you have latest version of Magento 2.

 

Eway extension is not compatible with your current version of Magento 2 , so you can contact Extension developer and ask them about compatible version of extension , or else new extension which is support magento 2.2.3

 

So at the end - issue is with eway extension packet , no error at magento side.

 

Hope it helps Smiley Happy


Thanks ManthanDave. The extension does say it is compatible with CE 2.1. so maybe it doesn't work with higher version. This is very annoying. I will get in touch with eWay because I just open an account with them. If it is not compatible, it is useless. 

 

Any suggestion which credit card payment extension is better? I picked eWay because their fee is much lower compared to others and the extension is free. They operate in Australia.

Re: Installing eWay extension on Magento CE 2.2.3

Hi @WZ_OZES

 

okay - i understand your concern !!

 

below i am sharing two links of Australian payment gateway extension for credit card which might help you for the same.

 

http://www.magepsycho.com/magento-2-e-path-credit-card-payment-gateway.html

 

https://bsscommerce.com/magento-anz-egate-payment-gateway-magento-2.html

 

hope it helps Smiley Happy

 

 

if issue solved,Click Kudos & Accept as Solution