cancel
Showing results for 
Search instead for 
Did you mean: 

Manual install fishpig/wordpress-integration

Manual install fishpig/wordpress-integration

Hi,

 

Started á project rebuilding/migrating Magento 1.9.x to 2.2.2

Currently i'm facing a problem installing the fishpig wordpress integration module.

The documentation found doesn't seem to solve my issue.

 

The error I get:

Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for fishpig/module-wordpress 1.2.0.28 -> satisfiable by fishpig/module-wordpress[1.2.0.28].
- fishpig/module-wordpress 1.2.0.28 requires magento/product-community-edition ^2.0.0 -> no matching package found.

 

Since the downloader isnt part of 2.2.2 anymore I am bound to manual installation.

 

Any ideas to resolve this are welcome.. thanks in advance

Tags (1)
2 REPLIES

Re: Manual install fishpig/wordpress-integration

Hi @FredDresken,

 

According with the compsoer .json file of the module:

 

https://github.com/bentideswell/magento2-wordpress-integration/blob/master/composer.json

 

Isn't compatible with Magento 2.2.2. Here you'll find a friendly explanation about versions restrictions: https://blog.madewithlove.be/post/tilde-and-caret-constraints/

 

So I guess you can:

 

  1. Try by userself changing the restriction (I don't recommend this option... think on this alternative like the last option)
  2. Open an issue on GitHub: https://github.com/bentideswell/magento2-wordpress-integration/issues
  3. Contact FishPig: https://fishpig.co.uk/magento-2/wordpress-integration/installation/

 

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Manual install fishpig/wordpress-integration

Hi @Damian Culotta

 

Got a reply from Ben Tideswell conforming the extention is 100% compatible with 2.2.2

Have to dive in the last resort option you gave, thanks for your quick response.