cancel
Showing results for 
Search instead for 
Did you mean: 

Problems installing extension from Marketplace

Problems installing extension from Marketplace

Hi,

 

We're running Magento Open Source 2.1.3.

We have not been able to install extensions from Marketplace using composer.

 

For example we're trying to install Klarna checkout using the following command:

composer require klarna/m2-checkout:3.0.0

 

And we get this output:

Screen Shot 2017-11-07 at 17.50.17.png

 

We're having the same problem we other modules. We know the package name is right because we purchased the module in marketplace and checked that information:

Screen Shot 2017-11-07 at 15.41.57.png

 

We have specified

https://repo.magento.com/ as one of our repositories in our composer.json file.

 

Can anyone give us a tip of what might be the problem?

 

Thank you.

2 REPLIES

Re: Problems installing extension from Marketplace

Magento 2.1.3 is not supported (you can run 2.1.2 or 2.1.4 and higher, just not 2.1.3) because it was a very buggy release. Please try upgrading to a newer release of Magento and you should be able to install the module then.

Re: Problems installing extension from Marketplace

Hello @jbalca

 

please create one auth.json into your root folder add below code there

{
   "http-basic": {
      "repo.magento.com": {
         "username": "<public-key>", // get from magento (make sure you purchase from same account)
         "password": "<private-key>" // 
      }
   }
}

 

Then run 

composer require klarna/m2-checkout

If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"