cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to install B2B extension on Magento 2.2 Commerce

Unable to install B2B extension on Magento 2.2 Commerce

After installation of Magento 2.2 Commerce I am trying to install B2B extension using below command.

composer require magento/extension-b2b

But I am getting below error.

 

 

[InvalidArgumentException]                                                                                                                  
 Could not find package magento/extension-b2b at any version for your minimum-stability (alpha). Check the package spelling or your minimum  
 -stability 

Link for installation of B2B on Magento 2.2 Commerce.
http://devdocs.magento.com/guides/v2.2/comp-mgr/install-extensions/b2b-installation.html

 

How can I fix this error please guide me to right direction.

 

3 REPLIES

Re: Unable to install B2B extension on Magento 2.2 Commerce

Hi @Ramkishan222,


Magento B2B module is only for Magento Commerce (formerly Magento EE). Also, if I'm not wrong, you'll need to get an extra authorization or permission or something at least you buy the module.

Maybe you can refer to your sales contact.

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: Unable to install B2B extension on Magento 2.2 Commerce

Hello @Damian Culotta

 

Yes I have set username and password (public and private key) in auth.json file. But not found any solution. Although I have raised the ticket for it and waiting for their reply.

Re: Unable to install B2B extension on Magento 2.2 Commerce

Hi @Ramkishan222,

 

Well, in that case it seems you're following the the right steps.

So you'll need to wait a little bit or ask again to yoru sales executive/contact.

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"