cancel
Showing results for 
Search instead for 
Did you mean: 

After Installation of Test Site Can't Add Products

After Installation of Test Site Can't Add Products

Hello,

 

I am back again, feeling defeated and that I am not so smart...

 

After fixing my URL redirect problem. I have run into another problem.

 

I am trying to add a couple of test products to the site, as well as categories. But nothing Saves.

 

I go through the process of adding a product of category and click "save and continue" etc...but nothing saves.

 

I have tried the usual troubleshooting steps, index products, index this and that, clear the cache, made sure the product showed in stock, had a quantity, etc...but nothing works.

 

I installed magento onto my test hosting platform over at bluehost. I didn't upload any of the sample data this time around (I have reinstalled magento several times, each time dropping the tables in SQL, and having the install process build them back) I am on 1.9.x of magento.

 

Any ideas?

 

 

9 REPLIES

Re: After Installation of Test Site Can't Add Products

Can you check if you are able to find javascript issues?

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: After Installation of Test Site Can't Add Products

+1 to @Damian Culotta 

I agree it sounds like it is possible a Javascript issue.

 

If you don't know how to check for Javascript issues - use firebug or your other browser inspector tool, choose debugger & find the JS errors.

 

If there are no JS issues it could be a server issue. Enable your log reporting at

 

System -> Configuration  -> Developer  -> Log settings

 

See if anything is written to var/log - this will give you any indication of server configuration issues.


Freelance Web Developer - Graphic Designer - SEO Analyst
Conor Rhys Tomkins

Re: After Installation of Test Site Can't Add Products

Thanks guys, I will check it now.

 

Just to clarify, you want me to check for JS on the admin panel side or the actual website?

Re: After Installation of Test Site Can't Add Products

On the panel side.

A lot of actions are triggered by js functions and the idea is to check ir you're getting some of those errors.

--
If you've found one of my answers useful, please give "Kudos" or "Accept as Solution"

Re: After Installation of Test Site Can't Add Products

Only error I could find on the Manage Product Panel is this:

Product Error

 

 

Re: After Installation of Test Site Can't Add Products

These also just showed up

 

The character encoding of a framed document was not declared. The document may appear different if viewed without the document framing it. blank.html


The Web Console logging API (console.log, console.info, console.warn, console.error) has been disabled by a script on this page.


The character encoding of a framed document was not declared. The document may appear different if viewed without the document framing it.

Re: After Installation of Test Site Can't Add Products

Nothing saves actually,

 

 So I turned on the Log like you suggested and it showed "saved configuration..." in the green box at the top. Go to Base/var/log and nothing, go back into settings and the setting shows "no" for logs. Like I didn't even change it.

 

 

Re: After Installation of Test Site Can't Add Products

Try checking if your file permissions are set correctly. 

 

If your hosting server is using SuPHP or SuExec, set all files to 644 and all directories to 755. If the server doesn't use SuPHP or SuExec, you may need to set some of those files and directories to 666 and 777 like /media and /var. 

James Lee | Moderator • Magento Master
See My Recommended Magento Hosting & Security Tips

Re: After Installation of Test Site Can't Add Products

Have you tried to install firebug (on firefox), turn it on and watch for the response of the request occurs when click on Save And Continue button?