cancel
Showing results for 
Search instead for 
Did you mean: 

Can't load HTTPS after Upgrading to 1.9.3

Highlighted
New Contributor

Can't load HTTPS after Upgrading to 1.9.3

Hi everybody,

 

I have a problem needing your urgent help.

Installed magento v1.9.3 on my local.
Local xampp service runs without SSL. It works well.

 

But dev server runs on SSL. As you know https://xxx.com

After upgrading, can't load pages on dev server.

I can see below error on console.

Mixed Content: The page at 'https://xxx.com/admin' was loaded over HTTPS, but requested an insecure stylesheet 'http://xxx.com/skin/adminhtml/default/default/reset.css'. This request has been blocked; the content must be served over HTTPS.

But can load page with insecure method.


When upload empty magento v1.9.3 on dev server, install page was broken and I can see similar error with above.

 

I hope to run website on https.

Would you give me your hand?

 

Best regards

2 REPLIES
Contributor

Re: Can't load HTTPS after Upgrading to 1.9.3

Hello fnikita1010,

 

The mixed content message means some files are loading from insecure URL's (http). When insecure content is loaded your site can not be listed as secure.

 

In your example, you need to change the following:-

http://xxx.com/skin/adminhtml/default/default/reset.css

To

https://xxx.com/skin/adminhtml/default/default/reset.css

 

Hope I helped!

Leslie B.
Aspiration Hosting - Magento 1 & 2 Optimized Cloud Hosting
Problem solved? Click Accept as Solution!
2 x Certified

Re: Can't load HTTPS after Upgrading to 1.9.3

Or you could omit protocol part of the url altogether:

 

//xxx.com/skin/adminhtml/default/default/reset.css

 

This tells browser to use whatever protocol the main page is using.

Tanel Raja