cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot install Magento 1.9.2.3 from scratch

Cannot install Magento 1.9.2.3 from scratch

Magento 1.9.2.2 works perfectly. In my test environment I cleaned up all Magento 1.9.2.2 files and database and decided to install from scratch 1.9.2.3 without sample option. I uploaded all the files, I checked permissions, I created a new database. Installer starts, I fill in the information about database, but I can go further than this step.

 

In browser I get: 


Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log

 

In apache log I get this:


[Fri Feb 05 11:31:30 2016] [warn] [client 192.168.159.104] mod_fcgid: read data timeout in 40 seconds, referer: http://192.168.159.104/index.php/install/wizard/config/?config%5Bl ocale%5D=en_US&config%5Btimezone%5D=America%2FLos_Angeles&config%5Bcurrency%5D=USD
[Fri Feb 05 11:31:30 2016] [error] [client 192.168.159.104] Premature end of script heade rs: index.php, referer: http://192.168.159.104/index.php/install/wizard/config/?config%5B locale%5D=en_US&config%5Btimezone%5D=America%2FLos_Angeles&config%5Bcurrency%5D=USD

 

Database has 146 tables and 20.55. Sometimes I get 151 tables. Always the script stopped in 40 seconds. 

 

4 REPLIES

Re: Cannot install Magento 1.9.2.3 from scratch

Usually initial run / upgrade takes some time to update database structures which for some system causes timeouts. Keep reloading, until it's done; or alternatively increase execution time limit.

 

Also do you have anything in var/log folder?

Tanel Raja

Re: Cannot install Magento 1.9.2.3 from scratch

How would we go about increasgin execution time on server? in php admin? Also, was the orginal owner able to install 1.9.2.3? I would like to install this version as its compatibale with several extensions that I need to use on store. Thanks for any advice in advance!

Re: Cannot install Magento 1.9.2.3 from scratch

There're several ways to increase it php.ini is one way, .htaccess is another, .user.ini is yet another way. Not all may be available for your. In any case you must be aware what you're doing.

Tanel Raja

Re: Cannot install Magento 1.9.2.3 from scratch

Hi,

 

Just and addition info to @Pronto answer.

you can add to .htaccess (the easiest way if you use apache)

php_value max_execution_time 18000

or change php.ini to

max_execution_time = 18000

 

Problem solved? Click Accept as Solution!
Still stuck? Check out our documentation: http://magento.com/help/documentation