cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot reindex 'Category Products' Index Process Information

Cannot reindex 'Category Products' Index Process Information

Hosting on Microsoft Azure, as a web app from their gallery.  After deployment, I get a message to reindex.  Upon trying to reindex, the error;

  • There was a problem with reindexing process.

Logs from /var/log/excpetion are as follows.

 

2015-04-01T05:56:05+00:00 DEBUG (7): Exception message: SQLSTATE[42000]: Syntax error or access violation: 1103 Incorrect table name ''
Trace: #0 D:\home\site\wwwroot\lib\Varien\Db\Statement\Pdo\Mysql.php(110): Zend_Db_Statement_Pdo->_execute(Array)
#1 D:\home\site\wwwroot\app\code\core\Zend\Db\Statement.php(291): Varien_Db_Statement_Pdo_Mysql->_execute(Array)
#2 D:\home\site\wwwroot\lib\Zend\Db\Adapter\Abstract.php(480): Zend_Db_Statement->execute(Array)
#3 D:\home\site\wwwroot\lib\Zend\Db\Adapter\Pdo\Abstract.php(238): Zend_Db_Adapter_Abstract->query('DELETE FROM ``', Array)
#4 D:\home\site\wwwroot\lib\Varien\Db\Adapter\Pdo\Mysql.php(428): Zend_Db_Adapter_Pdo_Abstract->query('DELETE FROM ``', Array)
#5 D:\home\site\wwwroot\lib\Zend\Db\Adapter\Abstract.php(664): Varien_Db_Adapter_Pdo_Mysql->query('DELETE FROM ``')
#6 D:\home\site\wwwroot\app\code\core\Mage\Catalog\Model\Resource\Category\Indexer\Product.php(941): Zend_Db_Adapter_Abstract->delete(NULL)
#7 D:\home\site\wwwroot\app\code\core\Mage\Index\Model\Indexer\Abstract.php(143): Mage_Catalog_Model_Resource_Category_Indexer_Product->reindexAll()
#8 D:\home\site\wwwroot\app\code\core\Mage\Index\Model\Process.php(210): Mage_Index_Model_Indexer_Abstract->reindexAll()
#9 D:\home\site\wwwroot\app\code\core\Mage\Index\Model\Process.php(258): Mage_Index_Model_Process->reindexAll()
#10 D:\home\site\wwwroot\app\code\core\Mage\Index\controllers\Adminhtml\ProcessController.php(127): Mage_Index_Model_Process->reindexEverything()
#11 D:\home\site\wwwroot\app\code\core\Mage\Core\Controller\Varien\Action.php(418): Mage_Index_Adminhtml_ProcessController->reindexProcessAction()
#12 D:\home\site\wwwroot\app\code\core\Mage\Core\Controller\Varien\Router\Standard.php(250): Mage_Core_Controller_Varien_Action->dispatch('reindexProcess')
#13 D:\home\site\wwwroot\app\code\core\Mage\Core\Controller\Varien\Front.php(172): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#14 D:\home\site\wwwroot\app\code\core\Mage\Core\Model\App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
#15 D:\home\site\wwwroot\app\Mage.php(684): Mage_Core_Model_App->run(Array)
#16 D:\home\site\wwwroot\index.php(87): Mage::run('', 'store')

4 REPLIES

Re: Cannot reindex 'Category Products' Index Process Information

I have tried to reinstall three times and still get the same error. All the other indexes is reindexing, but not category products for some reason...

Re: Cannot reindex 'Category Products' Index Process Information

Hi,

 

I just solved this with help from the Azure support. The problem appears in the setup of the Magento-site where no root category is choosen. So what you need to do i choose one. Se my steps below.

 

Go to Admin Panel - > System -> Configuration and then click on Manage Stores on the left and under the Store Name click on Main Website Store.

 

And choose the Root Category to Default Category. (by Default you may see –Please Select a Category--)

 

Then save and test to reindex. This should fix the problem. It did for the support team, and it did for me.

 

The product group is notified to change the setup process so this will be set directly after install.

Re: Cannot reindex 'Category Products' Index Process Information

Thank you for posting this response.

 

We have a blog post here that discusses this: http://blogs.msdn.com/b/azureossds/archive/2015/04/16/magento-root-category.aspx

 

 

Re: Cannot reindex 'Category Products' Index Process Information

Thanks a lot, I wasnt able to figure it out for the past 3 days, you know how frustrating can that be!