cancel
Showing results for 
Search instead for 
Did you mean: 

Entering a valid URL when installing Magento 1.9.2?

SOLVED

Entering a valid URL when installing Magento 1.9.2?

When installing Magento 1.9.2, I couldn't go to the next step because a URL validation occurred that required entering a valid URL. I asked a question on Stackoverflow here. But I want to know the reason for this. Is there any security issue here? Can you explain this?

Problem solved? Click Accept as Solution!
5 REPLIES

Re: Entering a valid URL when installing Magento 1.9.2?

Hi,

 

You have install magento on local machine/server or web hosting with domain?

 

If you are installing on local machine then instead of localhost need to use ip address.

 

If you are using domain then please provide error message you are getting and enviroment you are using like php,windows ,linux server or any other details.

 

 

-Thanks & Regards,Shahab

Re: Entering a valid URL when installing Magento 1.9.2?

Thanks you!

 

I installed on local. However, I want to know the reason why I can't use 'localhost'. Older versions of Magento accepted 'localhost' by default.

 

Thanks!

Problem solved? Click Accept as Solution!

Re: Entering a valid URL when installing Magento 1.9.2?

Its because localhost isn't actually a valid domain.since it doesn't have a TLD. I personally use localhost.com as mine so that it passes the URL checks. http://192.168.0.1/ etc.. is actually a valid domain which is why that passes the checks.

 

The is an option during install that says something along the lines of skip url verification that you could use if you're 100% sure you've got the right domain.

Problem solved? Click Accept as Solution!
Magento Certified Developer Plus | www.iwebsolutions.co.uk | Magento Small Business Partner

Re: Entering a valid URL when installing Magento 1.9.2?

Thanks you!

Problem solved? Click Accept as Solution!

Re: Entering a valid URL when installing Magento 1.9.2?

While installing Magento in the local server, in the configuration section, you may be asked to enter the base url. But the installation wizard will not accept the local server url. It is because

 

Magento won’t consider the local server url as a valid url.

 

For this you need to remove the validation for the particular section.

 

  • Open \app\design\install\default\default\template\install\config.phtml
  • Find the textbox where the base url is entered. It will be around line no 85 with name ‘config[unsecure_base_url]‘ Remove ‘validate-url’ from its class and save the file.

OR

Use Ip of your localhost,

 

http://127.0.0.1/magento/