cancel
Showing results for 
Search instead for 
Did you mean: 

Fresh New install 1.9.2 Asking SUPEE-6285

Fresh New install 1.9.2 Asking SUPEE-6285

I saw the new 09/07/2015 SUPEE-6285 v2 .

And 1.9.2 was include 07/07/2015 SUPEE-6285

After install message keep asking to install patch SUPEE-6285 immediately.

 

Can someone confirm if we need to install patch v2 released 09/07/2015 or Not ??

 

thks

3 REPLIES

Re: Fresh New install 1.9.2 Asking SUPEE-6285

Hello @qantas

 

I don't think Magento 1.9.2 version has added v2 of SUPEE 6285, so you will need to add that,

About the notification, those are just the message, you can mark as read and it wont show again.

 

 

Found something useful, please give "Kudos" or "Accept as Solution" for Token of Appreciation.
Free Magento Extensions : https://magecomp.com/free-magento-extensions.html

Re: Fresh New install 1.9.2 Asking SUPEE-6285

Keep in mind that the Magento messaging system is totally disconnected from any sort of mechanism that knows what version you have installed. It will stupidly show the message even though 1.9.2.0 does not need the SUPEE-6285 PATCH!!

 

----------------------------------------------------------------------------------------------------------------------------------------------------------------

 

Good pointer, we've got confused people out there trying to apply the SUPEE-6285 V1 to revert and then reapply SUPEE-6285 V2  to their Magento 1.9.2.0 installations.

 

Examining the code in the RWD checkout.phtml file shows it's already got the XSS patch, no need to mess with 1.9.2.0!

 

    <?php if($this->getContinueShoppingUrl()): ?>
        <button type="button" title="<?php echo $this->quoteEscape($this->__('Continue Shopping')) ?>" class="button2 btn-continue" onclick="setLocation('<?php echo Mage::helper('core')->quoteEscape($this->getContinueShoppingUrl()) ?>')"><span><span><?php echo $this->__('Continue Shopping') ?></span></span></button>
    <?php endif; ?>

 

For everyone out there, 1.9.2.0 is fine, the patch is for 1.9.x.x previous to this. If you applied the V1 patch, it's missing an update to the template file

 

app/design/frontend/rwd/default/template/checkout/cart.phtml

And you're better off just manually editing the file to change the line out and making a note in applied.patches.list

 

Remove    <button type="button" title="<?php echo $this->__('Continue Shopping') ?>" class="button2 btn-continue" onclick="setLocation('<?php echo $this->getContinueShoppingUrl() ?>')"><span><span><?php echo $this->__('Continue Shopping') ?></span></span></button>
Replace    <button type="button" title="<?php echo $this->quoteEscape($this->__('Continue Shopping')) ?>" class="button2 btn-continue" onclick="setLocation('<?php echo Mage::helper('core')->quoteEscape($this->getContinueShoppingUrl()) ?>')"><span><span><?php echo $this->__('Continue Shopping') ?></span></span></button>

 

Re: Fresh New install 1.9.2 Asking SUPEE-6285


theMageComp wrote:

Hello @qantas

 

I don't think Magento 1.9.2 version has added v2 of SUPEE 6285, so you will need to add that,

About the notification, those are just the message, you can mark as read and it wont show again.

 

 


Hmm, if you review the supposedly missing patch for RWD in SUPEE-6285 and comare it to your fresh 1.9.2.0 code base, you find that the V1 patch was missing the update for 1.9.x.x previous to 1.9.2.0 and 1.9.2.0 does not need a patch. You doom a 1.9.2.0 site maintainer to downloading V1, reverting unsuccessfully (several posts about that spread around the internet) and then trying to apply V2.

It's quite simple for a Magento developer to check whether the V2 patch has been applied to a new version of Magento, hmm?