cancel
Showing results for 
Search instead for 
Did you mean: 

How to run upgrade script manually...

SOLVED

How to run upgrade script manually...

Hello,

 

I'm currently experiencing some urgent problems with my Magento website.

 

I have upgraded my website from 1.9.0.0 to 1.9.1.0 and now it seems like the upgrade script (database) do not run entirely.

 

Table 'website.core_email_queue' doesn't exist' in /home/magento/lib/Zend/Db/Statement/Pdo.php:228

Some settings are also missing in the core_config_data tables... Is it possible to rerun the upgrade scripts manually because currently I can't find where... 

 

Some people suggest to modify the version in core_ressources but I don't think it's the best solution. I have triend to reinstall Mage_Core_Modules and Mage_Core_Adminhtml from the downloader but it doesn't seem to work.

 

I also have tried to redownload the core files of Magento and override core file in my setup, but it doesn't work at all. I can't get the missing tables created.

 

Thanks in advance,

Francis.

Tags (1)
3 REPLIES

Re: How to run upgrade script manually...

I realize this is not an answer, but it sure helps avoid future financial pain by not disabling your live server.

 

Create a staging server, run the upgrades on it until you've fixed all the problems.

 

Only after that do you even bother touching the live server.

 

Saves anywhere from hours to weeks of financial loss, costs less than the revenue you will lose when Magento upgrades go bad.

Re: How to run upgrade script manually...

I currently have a sort of staging server, but it can be better.

 

I have solved my problem by downgrading the version number in the table core_resource

 

Don't know if it's the best way to proceed, but it works.

 

Thanks!

Re: How to run upgrade script manually...

"I have solved my problem by downgrading the version number in the table core_resource. "

 

 so if i need to reupgrade my data what are the steps please, I am a noob what field in core_resource is downgraded? Then after its downgraded how do i reupgrade the data?