cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 1.9.1 new install, product does not show in front page.

Magento 1.9.1 new install, product does not show in front page.

Hi, I am relatively new using Magento, I installed CE 1.9.1 version , its a dedicated server running Linux unbutu server 14.04. The Magento installation process is smooth (its single store, without installing sample data) then I started with created a catalog first. then add a product into the catalog, but I realize the product does not show in front page. If I use "search" tool, the search tool does find the product I just added  displays it, but I was unable to view any product in the main page. 

 

I also installed a new theme called "Classic Theme for Magento" (http://www.magentocommerce.com/magento-connect/classic-theme-for-magento-10-colors-included.html), it appears installation went succesfull using Magento connect 2.0. however I can't find way to turn the new theme on. I went to System -> Configuration -> Design ->  Package - Current Package Name -> only showing "rwd" avaiable. I can't find way to switch to a different theme

 

Can someone shed some lights on this? I very much appreciate your help. 

6 REPLIES

Re: Magento 1.9.1 new install, product does not show in front page.

Hi!

 

Please run through this check list to see why your product won't show up; http://www.aschroder.com/2010/07/why-are-my-magento-products-not-showing-up/

 

it is most likely in one of those configurations.

 

Concerning the theme; you just replace the 'rwd' with the name of the package you've installed. You can find the name used on the server in the folder app/design/frontend.

Re: Magento 1.9.1 new install, product does not show in front page.

Hi,

 

First products on the homepage (meaining home/first page in the shop), you will have to edit the cms page - with identifier "home".

 

Go to cms > pages > find the one with "home" in identifier.

 

When loaded press the content tab on the left side, click on WYSIWYG editor once (so you can paste raw html in) and insert this line of code:

 

{{block type="catalog/product_new" column_count="6" products_count="12" name="home.catalog.product.new" alias="product_homepage" template="catalog/product/list.phtml"}}

 

Where:

column_count="6" – number of the product columns
products_count="12" – number of the displayed products

 

For the design:

 

1) Clear you cache under System > Cache Management > Cache (empty all of them).

2) Go to System > Design > Choose package "10 color theme", that you downloaded.

 

Hope this helps, else lets me know Smiley Happy

 

-- Best regards --
Kent Christiansen / @KentChrDK / Magento Certified Solution Specialist / Visit my site (DK)

Re: Magento 1.9.1 new install, product does not show in front page.

Good morning,

 

I hope someone can help - I have recently installed Magento 1.9 and have configured it sucessfully so that both the frontend and backend are visible (demo only).

 

However when the admin panel loads and the user details are inputted the log in page just reloads and won't let me get passed this point. The page loads with a new key at the end of the URL each time and if the inccorrect username or password are inputted this is detected and renders with the relevant error. 

 

I have looked around and a lot of people have advised amending the varien.php file which I have tried but the problem still persists. 

 

If anyone could offer any advice or help that would be great!

 

Many thanks,

Richard

Re: Magento 1.9.1 new install, product does not show in front page.

Hi Richard, Could you open your own topic? Hijacking someone else's topic isn't advisable. Thanks!

Re: Magento 1.9.1 new install, product does not show in front page.

Hi Bamboo,

You may find your solution in this tutorial (I'm not sure if it works perfect on Magento 1.9 as the tutorial was written for older versions)

http://tutorialmagento.com/how-to-display-latest-products-on-homepage-in-magento

 

Hope this helps,

Brian

Re: Magento 1.9.1 new install, product does not show in front page.

I am new at it, but I went to inventery and where it says manage stock I un click use config settings then cliclk no instead of yes, I am still trying to work the rest out and its doing my head in, LOL