cancel
Showing results for 
Search instead for 
Did you mean: 

Magento 1.9 - Missing Extensions

Magento 1.9 - Missing Extensions

Currently, our developers are trying to install Magento 1.9 to our server. 

Our dedicated server account is with Bluehost.com - we had a plan with them previously, but it was a VPS plan - it turned out that it didn't suit our needs so they told us to go to a dedicated server account. We're getting this message. 

 

Your server does not meet the following requirements in order to install Magento.
The following requirements failed, please contact your hosting provider in order to receive assistance with meeting the system requirements for Magento:

  • You are missing the curl extension
  • You are missing the dom extension
  • You are missing the gd extension
  • You are missing the iconv extension
  • You are missing the mcrypt extension
  • You are missing the pdo extension
  • You are missing the pdo_mysql extension
  • You are missing the simplexml extension

 

The following requirements were successfully met:

  • You have the hash extension
  • You have the pcre extension

 

The developers assure me that they have tried everything they can on their end to solve the problem, and Blue-host seem unable to solve this problem also. It seems difficult to get into direct contact with tech support at Magento, so I thought I'd ask here. 

 

Magento was working correctly with our previous plan. 

1 REPLY

Re: Magento 1.9 - Missing Extensions

Should not be that big issue. Seems like those modules are not enabled in PHP.ini. There may be some communication gap between Bluehost and Your Developer.

 

You are having a dedicated server and such small issues can be resolved very quickly. Setup a call between your developer and bluehost and be a part of it to understand what is going on.

 

Time to change the developer or hosting....

Thanks,
Tarandeep
Magento 2 Certified Solution Specialist (x2). Follow me on Twitter