cancel
Showing results for 
Search instead for 
Did you mean: 

MySQL 5.1.65

MySQL 5.1.65

Hi All.

 

Trying to install Magento 1.9.2.1 and have "database connection error". tryed 127.0.0.1 solution, checked all credintials...

Nothing helps.

When I check compability - have message "

  • You need MySQL 4.1.20 (or greater)

But on my server i have MySQL 5.1.65...

 Please help me.

 

Sincerely,

George

1 REPLY

Re: MySQL 5.1.65

Hi,

This is pasted direct from another thread that I responded too:

--

This is likely because you have some of your database details entered wrong or a permission issue whilst trying to connect.

 

Can you check in you var/log/exception.log file to see if there are any errors in there?

 

If you don't see anything in there... edit the file app\code\core\Mage\Install\Model\Installer\Db.php and find the below code:

Mage::throwException(Mage::helper('install')->__('Database connection error.'));

Change it too:

Mage::throwException(Mage::helper('install')->__($e->getMessage()));

This time when you try it should output some error message indicating which part of your setup was wrong.

 

Let us know how you get on.

Problem solved? Click Accept as Solution!
Magento Certified Developer Plus | www.iwebsolutions.co.uk | Magento Small Business Partner