cancel
Showing results for 
Search instead for 
Did you mean: 

No input file specified magento 1.9 install godaddy

SOLVED

No input file specified magento 1.9 install godaddy

Receiving this error message "No input file specified." When trying to do a fresh install of 1.9 on the Go Daddy server. I have not even gotten to any of the set up pages. I'm just that index.php\install

Any ideas?
3 REPLIES

Re: No input file specified magento 1.9 install godaddy

Okay I have figured it out finally.

You have to disable "FastCGI" in the .htaccess in the root directory. You may have to access the files via the go daddy file manager as sometimes this file cannot be seen in standard FTP programs.

Open up the .htaccess file and add Options +ExecCGI to a new line and save the file.

No clear your catch a refresh the page your message should be gone now and you should be able to continue your installation of magento.

Re: No input file specified magento 1.9 install godaddy

Thanks for sharing this quirk with GoDaddy with the community. 

 

I've set your second response as the "Solution" so other users can better find the correct solution if they come across the same problem. Smiley Happy

James Lee | Moderator • Magento Master
See My Recommended Magento Hosting & Security Tips

Re: No input file specified magento 1.9 install godaddy

A common error,  comes up if you’re hosted by GoDaddy, is the no input file specified error. If you do not have Magento setup in the root of your server, make sure to add the following to your .htaccess file. RewriteBase /yourbasepath/ Once that is verified, there are a couple things you can do to fix this, but we’ll start with the one that usually works. In your web root directory, there should be a file called php.ini. Rename this to php5.ini. If there is no php5.ini file. Create the file and upload it to your root directory. If that doesn’t work, add the following to the end of your newly renamed php5.ini file: cgi.fix_pathinfo = 1 And if you’re still getting the error, add the following to the top of your .htaccess file: Options -MultiViews The first one usually does the trick. If you don’t see this file in there, then create a blank php5.ini file add add the line listed on the second suggestion. If all of the above has not worked, KEEP your changes, wait exactly 24 hours. Go back to youraddress.tld/downloader and try again. You may just be cached and for some reason it takes a bit longer then I was used to. Keep your chin up! If nothing above worked, call GoDaddy up and have them either rename this for you, or make sure you’re on PHP 5.