cancel
Showing results for 
Search instead for 
Did you mean: 

PHP Extensions "pdo_mysql" must be loaded

PHP Extensions "pdo_mysql" must be loaded

I am getting this error on the Database configuration page when installing Magento 1.7.0.2.  My PHP version is 5.5.9 and my MySQL version is 5.5.  I am fairly certain I have pdo_mysql installed, but am unable to find any kind of method to install it...I've also read it was native to my PHP version.

 

I have already tried the following:

 

  • Adding ; pdo

extension=pdo.so
extension=pdo_mysql.so

 

to my php.ini file

  • Restarting Apache2

Any additional suggestions would be greatly appreciated.

3 REPLIES

Re: PHP Extensions "pdo_mysql" must be loaded

you need to check php loaded modules, like:

php -m | grep -i pdo

 or just create php info page , and see everything you have there

 

not sure how it was installed: compiled or package manager

 

------------
MagenX - Magento and Server optimization

Re: PHP Extensions "pdo_mysql" must be loaded

I added these three lines to my php.ini file and it worked out for me.

 

extension=pdo_mysql.so
extension=pdo_mysqli.so
extension=pdo.so

Re: PHP Extensions "pdo_mysql" must be loaded

thank you - worked as a charm.