cancel
Showing results for 
Search instead for 
Did you mean: 

Question - is 1.9.2.4 compatible with PHP 7

Question - is 1.9.2.4 compatible with PHP 7

Hello

 

We have two sites. One is a new one that we are trying to build on 2.1 and one is old on 1.9.2.4. Both on the same server

 

I am thinking of upgrading to PHP 7 on the server.

 

Will the 1.9.2.4 site run on PHP 7?

 

Thanks very much

Sam

Tags (1)
4 REPLIES

Re: Question - is 1.9.2.4 compatible with PHP 7

Short answer is no, it doesn't. Magento CE 1.9.2.4 only supports PHP 5.4 and 5.5 officially. And while PHP 5.6 runs it just fine, it saturates log files with multitudes of warning messages.

 

Long answer is that it's relatively easy to modify it to run support PHP7. However many extensions are still not PHP7 compatible so you're largely on your own. Magento was supposed to release new Magento 1.x July 2016, but ... 

Tanel Raja

Re: Question - is 1.9.2.4 compatible with PHP 7

Magento2 is ready for PHP 7. Adaptation of code to PHP7 was done and all changes are available in develop branch.

Also, support of php 7 in Magento1 require backward incompatible changes and I think will be not supported officially.

Re: Question - is 1.9.2.4 compatible with PHP 7

Hi,

You can use Magento 1.9 with the Inchoo's patch(without additional extensions), Also there is  a problem with either a third party extension or custom code.

you also can check php7 compatibility test using following https://github.com/sstalle/php7cc

 

Thanks

Jigneshkumar aakoliya

http://www.ifourtechnolab.com/

Re: Question - is 1.9.2.4 compatible with PHP 7

If you want to use PHP 7 than use magento 2. However, if you have a lot of extensions moving to 2 may cause problems. I personally don't like 2 backend.