cancel
Showing results for 
Search instead for 
Did you mean: 

URL paths not correct

SOLVED

URL paths not correct

It seems that for some strange reason, I have to include the index.php/ in order for my URL paths to work, I left things with the default on the install, how do I fix this 

 

IE: to get the admin I WANT to use:

 

http://www.domainname.com/admin

 

but its requiring me to enter the following:

http://www.domainname.com/index.php/admin

 

5 REPLIES

Re: URL paths not correct

Hi,

 

You need to enable Url Rewrite on yoru server and  then Log-in to your Magento administration area System > Configuration > Web navigate to 'Search Engine Optimisation' tab and select 'YES' underneath the 'Use Web Server Rewrites' option.

 

Also after it clean cache and reindex the website.  If everything configured correctly /index.php/ will dissapear from links and admin panel will be avaiable without it too.

 

Thanks

Re: URL paths not correct

I did that, what's happening now is this:

 

I'm entering the following:

 

https://www.domainname.com/admin

 

and its changing it to:

https://www.domainname.comadmin

 

Re: URL paths not correct

Ok I think I found the issue.  In the httpd.conf we have a redirect / to https but it did not have a trailing / so that appears to be the issue.

 

Re: URL paths not correct


dpalme wrote:

Ok I think I found the issue.  In the httpd.conf we have a redirect / to https but it did not have a trailing / so that appears to be the issue.

 


Thank you for reporting back to the community with your solution. 

 

I have marked it as the "Solution" so others who face the same issue can easily find the correct answer. 

James Lee | Moderator • Magento Master
See My Recommended Magento Hosting & Security Tips

Re: URL paths not correct

I always try....