cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade 1.5.1.0 to anything

Upgrade 1.5.1.0 to anything

Hi, 
We haven't used our website in years, I have taken over and I'm looking to make it much better - starting with an upgrade. In connect manager I have tried downloading 1.9.2.4 & 1.2.1.0. I receive the error No Files Uploaded and this is in my output frame. Any suggestions?

Checking dependencies of packages
Already installed: community/Lib_Cm 1.9.2.4, skipping
Already installed: community/Cm_RedisSession 1.9.2.4, skipping
Already installed: community/Interface_Frontend_Rwd_Default 1.9.2.4, skipping
Already installed: community/Lib_Magento 1.9.2.4, skipping
Already installed: community/Lib_Credis 1.9.2.4, skipping
Already installed: community/Lib_Pelago 1.9.2.4, skipping
Already installed: community/Lib_Unserialize 1.9.2.4, skipping
Already installed: community/Lib_IDNA2 1.9.2.4, skipping

CONNECT ERROR: Package 'Mage_All_Latest' is invalid
'./pkginfo/Mage_All_Latest.txt' already exists
Package 'Interface_Adminhtml_Default' is invalid
'./app/design/adminhtml/default/default/layout/admin.xml' already exists
Package 'Interface_Frontend_Default' is invalid
'./app/design/frontend/default/default/etc/widget.xml' already exists
Package 'Interface_Install_Default' is invalid
'./app/design/install/default/default/layout/main.xml' already exists
Package 'Mage_Downloader' is invalid
'./downloader/js/prototype.js' already exists
Package 'Mage_Centinel' is invalid
'./app/code/core/Mage/Centinel/Block/Adminhtml/Validation/Form.php' already exists
Package 'Interface_Frontend_Base_Default' is invalid
'./app/design/frontend/base/default/etc/widget.xml' already exists
Package 'Phoenix_Moneybookers' is invalid
'./app/code/community/Phoenix/Moneybookers/Block/Form.php' already exists
Package 'Mage_Compiler' is invalid
'./app/code/core/Mage/Compiler/Block/Process.php' already exists
Package 'Magento_Mobile' is invalid
'./app/code/core/Mage/XmlConnect//Block/Adminhtml/History/Grid.php' already exists
Package 'Mage_Core_Adminhtml' is invalid
'./app/code/core/Mage/Adminhtml/Block/Abstract.php' already exists
Package 'Mage_Core_Modules' is invalid
'./app/code/core/Mage/Admin/Model/Acl/Assert/Ip.php' already exists
Package 'Lib_Js_Ext' is invalid
'./js/extjs/css/README.txt' already exists
Package 'Lib_LinLibertineFont' is invalid
'./lib/LinLibertineFont/Bugs' already exists
Package 'Lib_Js_TinyMCE' is invalid
'./js/tiny_mce/classes/AddOnManager.js' already exists
Package 'Lib_Varien' is invalid
'./lib/Varien/Autoload.php' already exists
Package 'Lib_Google_Checkout' is invalid
Empty package contents section
Package 'Lib_Js_Calendar' is invalid
'./js/calendar/calendar-blue.css' already exists
Package 'Lib_Js_Mage' is invalid
'./js/lib/FABridge.js' already exists
Package 'Lib_Phpseclib' is invalid
'./lib/phpseclib/Crypt/AES.php' already exists
Package 'Mage_Locale_en_US' is invalid
'./app/locale/en_US/Mage_AdminNotification.csv' already exists
Package 'Lib_Mage' is invalid
'./lib/Mage/Archive/Abstract.php' already exists
Package 'Lib_ZF' is invalid
'./lib/Zend/Acl/Assert/Interface.php' already exists
Package 'Lib_Js_Prototype' is invalid
'./js/prototype/debug.js' already exists
Package 'Lib_ZF_Locale' is invalid
'./lib/Zend/Locale/Data/Translation.php' already exists 

2 REPLIES

Re: Upgrade 1.5.1.0 to anything

Navigate to downloader\lib\Mage\Connect\Validator.php and comment out the following code:

 

if (file_exists($dest)) {
$this->addError("'{$file}' already exists");
return false;
}
Tanel Raja

Re: Upgrade 1.5.1.0 to anything

Anw, you can upgrade magento 1.5 to 1.9, 2.0, 2.1 or 2.2 now. I suggest Magento upgrade service of Lit-Extension. People choose it when they dont have enough time to research about data migration and look for an automated solution. When migrating data, many errors can occur with a few guide for solving problems. It is dangerous for keeping database. You can read Magento upgrade guide and consider it to upgrade magento 1.5 to the higher version of magento.