cancel
Showing results for 
Search instead for 
Did you mean: 

cannot upgrade to Magento v.1.9.4.0 because of PHP7?

Highlighted

cannot upgrade to Magento v.1.9.4.0 because of PHP7?

We are running Magento v.1.9.3.10. Our server has PHP 7.0.32 installed.

I just tried to upgrade to Magento v.1.9.4.0 - then I received this error message in Connect Manager:

CONNECT ERROR: Package community/Mage_All_Latest 1.9.4.0: requires PHP version >= 5.2.0 and <= 6.0.0 current is: 7.0.32-1~dotdeb+8.1

Is anyone having an idea, what to do in this case? I don't want to go back tp PHP 5.6 to avoid this problem.

Thanks in advance,

Mario

 

 

 

2 REPLIES 2
Highlighted

Re: cannot upgrade to Magento v.1.9.4.0 because of PHP7?

Hi @blueskies7777,

You can texplore this stack exchange solutions since you may have faced same issue. Here I can share the link below
https://magento.stackexchange.com/questions/108156/magento-1-9-2-2-upgrade-to-1-9-2-4-fails-via-conn...

If my solution is useful, give kudos & accept as solution

Best regards
Madhuresan
Bootsgrid

Highlighted

Re: cannot upgrade to Magento v.1.9.4.0 because of PHP7?

I was able to successfully update Magento 1.9.4.0 to 1.9.4.1 using Magento Connect by downgrading PHP to 5.6, performing the update, and then switching the PHP back to 7.2.