cancel
Showing results for 
Search instead for 
Did you mean: 

evaluation error

evaluation error

Hi there,

 

I opened my store and saw a big error:

 

error evaluating function `darken`: 'undefined' is not a function (evaluating 'e.toHSL()')

in theme.less

There are a lot of red sentences with .js

How to fix?

Regards,

5 REPLIES

Re: evaluation error

Please show us your errors

Magento Moderator since 2009
Keep Calm and Clear Cache!

Re: evaluation error

Hi...

 

@smartgrafik

Did you managed to fix the error? It just happened to me and I don't know what to do.

 

http://fireonboardjogos.com.br/

 

Please, someone?

Re: evaluation error

Hi there,

 

yes, I fixed every issue. 

 

But I do not know now the solution for this error.

 

Please search on google, you will find it! Best way.

 

Good luck.

Re: evaluation error

In my case this started to happen after I switched an option in the theme settings.

 

This is what I sent to the theme support center:

 

 

I'll explain the whole history...
The last time the site was working normally I tried to change the option "Disable responsive css" to YES. As soon as I did that and hit refresh on my site, everything went wrong. The problem is described here:
http://community.magento.com/t5/Installing-Magento/evaluation-error/m-p/8763#M1160

Fortunatelly I got a "solution" removing all the lines with the path em0121, under the core_config_data table in the database. This resets all the theme settings and the problem is gone until I change any settings on the theme and hit save. So I'm stucked with the default settings right now.

I'm not sure about that, but it seems that javascript is removing the # from all the hexadecimal values in the em0121 settings, then the code is not recognizing those colors, but maybe the problem is more complex than that, you tell me.

I need to fix that, otherwise I will not be able to change any option on the theme settings.

 

Re: evaluation error

The problem is, that the colors are set to null in the database. On Admin interface template settings change, it over writes those null values for the colors to FFFFFF. 

I changed it back using query: 

UPDATE `core_config_data` SET `value` = NULL WHERE `value` = 'FFFFFF'

 

This fixed the problem for me without removing all the records.