cancel
Showing results for 
Search instead for 
Did you mean: 

login form and payment not working version 1.9.1

login form and payment not working version 1.9.1

I use to have version 1.7.  Then I have updated it with version 1.9.1( full release) from admin panel. After few tweaks the website was live again. But now i have issue of loging and payment system not working both paypal and sagepay.

After reading somewhere then i downloaded and reinstalled this version again manually by using ftp but both errors below still same

 

I m new to magento and this site is done by other company before. I got two major issue at the minute

 

1) Everytime i login it goes to login page without any error message on the page.

2) every time i try to place an order (step 6 of payment) it stucks on /checkout/onepage/ and it shows not error message at all but just stays on same page /checkout/onepage/.

 

Can anyone have an idea whats going wrong. Realy stuck from yesterday. Thanks

 

 

 

5 REPLIES

Re: login form and payment not working version 1.9.1

That's because version 1.7.x didn't have form keys yet. In Magento 1.9.x, they added form keys to (almost) every frontend form there is. I think you're using a custom theme for your webshop, so you'll need to manually add the form keys to your own design.

 

The forms I know that have form keys are:

  • app/design/frontend/base/default/template/catalog/product/view.phtml
  • app/design/frontend/base/default/template/checkout/cart.phtml
  • app/design/frontend/base/default/template/checkout/multishipping/overview.phtml
  • app/design/frontend/base/default/template/checkout/onepage/login.phtml
  • app/design/frontend/base/default/template/customer/address/edit.phtml
  • app/design/frontend/base/default/template/customer/form/edit.phtml
  • app/design/frontend/base/default/template/customer/form/login.phtml
  • app/design/frontend/base/default/template/customer/form/newsletter.phtml
  • app/design/frontend/base/default/template/persistent/checkout/onepage/login.phtml
  • app/design/frontend/base/default/template/persistent/customer/form/login.phtml
  • app/design/frontend/base/default/template/review/form.phtml
  • app/design/frontend/base/default/template/sales/reorder/sidebar.phtml
  • app/design/frontend/base/default/template/sendfriend/send.phtml
  • app/design/frontend/base/default/template/wishlist/sharing.phtml
  • app/design/frontend/base/default/template/wishlist/view.phtml
  • app/design/frontend/base/default/template/wishlist/view.phtml

 

Maybe there are more, because of extensions you installed, but it's easy to find which template files need to be altered. Just check your installation for the text "$this->getBlockHtml('formkey')". That's the block that's used to implement the form key.

If this response was helpful to you, consider giving kudos to this post.
If this response solved your problem, click accept as solution to help others solve this

Re: login form and payment not working version 1.9.1

thanks . i am going to apply these changes and will post here the result.

 

 

cheers mate.

Re: login form and payment not working version 1.9.1

I m trying to change them in app/design/frontend/base/default/template/catalog/product/view.phtml but there is line like this, do i have to change it, can u please have a look at it, thanks

 

 

<form action="<?php echo $this->getSubmitUrl($_product) ?>" method="post" id="product_addtocart_form"<?php if($_product->getOptions()): ?> enctype="multipart/form-data"<?php endif; ?>>
<?php echo $this->getBlockHtml('formkey') ?>

 

 

wht shall i add here or leave it like that.

Re: login form and payment not working version 1.9.1

Thanks for the reply. I changed almost all the files you mentioned above and some more login files because there are so many on other folders. So login works fine now.

 

Also update cart was not working and i made some change in one update file and it worked fine too.

 

But problem now is payment,

 

whenever i click Place Order , it stays on same page. any idea, i am realy stuck. thanks

Re: login form and payment not working version 1.9.1

Did you solve this last problem? We are having the same problem (mostly only with Safari on iOS/ MacOS) and can't solve it.