cancel
Showing results for 
Search instead for 
Did you mean: 

500 ERROR

SOLVED

500 ERROR

Hi I am new to Magento but not sure I will become an old hand.

 

Spent about 4 hours trying to get it to install via the http ..../setup and I have had no luck at all in chrome all I get is http 500 errors, I even tried making the whole file structure 777 but no that was just as unsuccecful. an index.htmp file works as does adding echo :"test"; die("dead"); it displays test dead.

 

I see its been an on going issues but I dont see no resolutions any place apparent.

 

I run 

Centos 7-1708, php 7.2.1,  apache 2.4,  mariadb 5.5.65, all other requirements seem to be met

 

If anybody knows anything can you let me know please

 

Cheers, Neil

 

** Dell Optiplex 9010, Intel Core I5, 16GB Memory, Centos 7.4 **
** PHP 7.1.16, MariaDB 10.1.11 **
18 REPLIES

Re: 500 ERROR

okay - does it mean magento 2 installed successfully at your end but when you are opening its giving 500 error ? or it is not installed yet ?

 

Also to check its installed or not check your database - is there any tables is created of Magento 2.

 

 

if issue solved,Click Kudos & Accept as Solution

Re: 500 ERROR

Hi, and thanks no it wont install at all, it gets the error early on in the setup/index.php script. the scripts and dies with the error.

 

There are no tables created in the database. 

 

Cheers. Neil 

** Dell Optiplex 9010, Intel Core I5, 16GB Memory, Centos 7.4 **
** PHP 7.1.16, MariaDB 10.1.11 **

Re: 500 ERROR

okay - i understand , Can you confirm you have .htaccess file in root directory of Magento 2 ?

if issue solved,Click Kudos & Accept as Solution
Tags (1)

Re: 500 ERROR

Yes, just the standard one as per distribution, I did try and rename it but that made no difference

** Dell Optiplex 9010, Intel Core I5, 16GB Memory, Centos 7.4 **
** PHP 7.1.16, MariaDB 10.1.11 **

Re: 500 ERROR

okay i understand , kindly replace below code with the existing .htacceess file.

 

############################################
## overrides deployment configuration mode value
## use command bin/magento deploy:mode:set to switch modes

#   SetEnv MAGE_MODE developer

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

#    Action php5-cgi /cgi-bin/php5-cgi
#    AddHandler php5-cgi .php

############################################
## GoDaddy specific options

#   Options -MultiViews

## you might also need to add this line to php.ini
##     cgi.fix_pathinfo = 1
## if it still doesn't work, rename php.ini to php5.ini

############################################
## this line is specific for 1and1 hosting

    #AddType x-mapp-php5 .php
    #AddHandler x-mapp-php5 .php

############################################
## default index file

    DirectoryIndex index.php

<IfModule mod_php5.c>
############################################
## adjust memory limit

    php_value memory_limit 756M
    php_value max_execution_time 18000

############################################
## disable automatic session start
## before autoload was initialized

    php_flag session.auto_start off

############################################
## enable resulting html compression

    #php_flag zlib.output_compression on

###########################################
## disable user agent verification to not break multiple image upload

    php_flag suhosin.session.cryptua off
</IfModule>
<IfModule mod_php7.c>
############################################
## adjust memory limit

    php_value memory_limit 756M
    php_value max_execution_time 18000

############################################
## disable automatic session start
## before autoload was initialized

    php_flag session.auto_start off

############################################
## enable resulting html compression

    #php_flag zlib.output_compression on

###########################################
## disable user agent verification to not break multiple image upload

    php_flag suhosin.session.cryptua off
</IfModule>
<IfModule mod_security.c>
###########################################
## disable POST processing to not break multiple image upload

    SecFilterEngine Off
    SecFilterScanPOST Off
</IfModule>

<IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

    # Insert filter on all content
    ###SetOutputFilter DEFLATE
    # Insert filter on selected content types only
    #AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript application/javascript application/x-javascript application/json image/svg+xml

    # Netscape 4.x has some problems...
    #BrowserMatch ^Mozilla/4 gzip-only-text/html

    # Netscape 4.06-4.08 have some more problems
    #BrowserMatch ^Mozilla/4\.0[678] no-gzip

    # MSIE masquerades as Netscape, but it is fine
    #BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

    # Don't compress images
    #SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

    # Make sure proxies don't deliver the wrong content
    #Header append Vary User-Agent env=!dont-vary

</IfModule>

<IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

    SSLOptions StdEnvVars

</IfModule>

############################################
## workaround for Apache 2.4.6 CentOS build when working via ProxyPassMatch with HHVM (or any other)
## Please, set it on virtual host configuration level

##    SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1
############################################

<IfModule mod_rewrite.c>

############################################
## enable rewrites

    Options +FollowSymLinks
    RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

    #RewriteBase /magento/

############################################
## workaround for HTTP authorization
## in CGI environment

    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## TRACE and TRACK HTTP methods disabled to prevent XSS attacks

    RewriteCond %{REQUEST_METHOD} ^TRAC[EK]
    RewriteRule .* - [L,R=405]

############################################
## redirect for mobile user agents

    #RewriteCond %{REQUEST_URI} !^/mobiledirectoryhere/.*$
    #RewriteCond %{HTTP_USER_AGENT} "android|blackberry|ipad|iphone|ipod|iemobile|opera mobile|palmos|webos|googlebot-mobile" [NC]
    #RewriteRule ^(.*)$ /mobiledirectoryhere/ [L,R=302]

############################################
## never rewrite for existing files, directories and links

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

    RewriteRule .* index.php [L]

</IfModule>


############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

    AddDefaultCharset Off
    #AddDefaultCharset UTF-8
    AddType 'text/html; charset=UTF-8' html

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

    ExpiresDefault "access plus 1 year"
    ExpiresByType text/html A0
    ExpiresByType text/plain A0

</IfModule>

###########################################
## Deny access to root files to hide sensitive application information
    RedirectMatch 403 /\.git

    <Files composer.json>
        <IfVersion < 2.4>
            order allow,deny
            deny from all
        </IfVersion>
        <IfVersion >= 2.4>
            Require all denied
        </IfVersion>
    </Files>
    <Files composer.lock>
        <IfVersion < 2.4>
            order allow,deny
            deny from all
        </IfVersion>
        <IfVersion >= 2.4>
            Require all denied
        </IfVersion>
    </Files>
    <Files .gitignore>
        <IfVersion < 2.4>
            order allow,deny
            deny from all
        </IfVersion>
        <IfVersion >= 2.4>
            Require all denied
        </IfVersion>
    </Files>
    <Files .htaccess>
        <IfVersion < 2.4>
            order allow,deny
            deny from all
        </IfVersion>
        <IfVersion >= 2.4>
            Require all denied
        </IfVersion>
    </Files>
    <Files .htaccess.sample>
        <IfVersion < 2.4>
            order allow,deny
            deny from all
        </IfVersion>
        <IfVersion >= 2.4>
            Require all denied
        </IfVersion>
    </Files>
    <Files .php_cs.dist>
        <IfVersion < 2.4>
            order allow,deny
            deny from all
        </IfVersion>
        <IfVersion >= 2.4>
            Require all denied
        </IfVersion>
    </Files>
    <Files .travis.yml>
        <IfVersion < 2.4>
            order allow,deny
            deny from all
        </IfVersion>
        <IfVersion >= 2.4>
            Require all denied
        </IfVersion>
    </Files>
    <Files CHANGELOG.md>
        <IfVersion < 2.4>
            order allow,deny
            deny from all
        </IfVersion>
        <IfVersion >= 2.4>
            Require all denied
        </IfVersion>
    </Files>
    <Files CONTRIBUTING.md>
        <IfVersion < 2.4>
            order allow,deny
            deny from all
        </IfVersion>
        <IfVersion >= 2.4>
            Require all denied
        </IfVersion>
    </Files>
    <Files COPYING.txt>
        <IfVersion < 2.4>
            order allow,deny
            deny from all
        </IfVersion>
        <IfVersion >= 2.4>
            Require all denied
        </IfVersion>
    </Files>
    <Files Gruntfile.js>
        <IfVersion < 2.4>
            order allow,deny
            deny from all
        </IfVersion>
        <IfVersion >= 2.4>
            Require all denied
        </IfVersion>
    </Files>
    <Files LICENSE.txt>
        <IfVersion < 2.4>
            order allow,deny
            deny from all
        </IfVersion>
        <IfVersion >= 2.4>
            Require all denied
        </IfVersion>
    </Files>
    <Files LICENSE_AFL.txt>
        <IfVersion < 2.4>
            order allow,deny
            deny from all
        </IfVersion>
        <IfVersion >= 2.4>
            Require all denied
        </IfVersion>
    </Files>
    <Files nginx.conf.sample>
        <IfVersion < 2.4>
            order allow,deny
            deny from all
        </IfVersion>
        <IfVersion >= 2.4>
            Require all denied
        </IfVersion>
    </Files>
    <Files package.json>
        <IfVersion < 2.4>
            order allow,deny
            deny from all
        </IfVersion>
        <IfVersion >= 2.4>
            Require all denied
        </IfVersion>
    </Files>
    <Files php.ini.sample>
        <IfVersion < 2.4>
            order allow,deny
            deny from all
        </IfVersion>
        <IfVersion >= 2.4>
            Require all denied
        </IfVersion>
    </Files>
    <Files README.md>
        <IfVersion < 2.4>
            order allow,deny
            deny from all
        </IfVersion>
        <IfVersion >= 2.4>
            Require all denied
        </IfVersion>
    </Files>
    <Files auth.json>
        <IfVersion < 2.4>
            order allow,deny
            deny from all
        </IfVersion>
        <IfVersion >= 2.4>
            Require all denied
        </IfVersion>
    </Files>
    <Files magento_umask>
        <IfVersion < 2.4>
            order allow,deny
            deny from all
        </IfVersion>
        <IfVersion >= 2.4>
            Require all denied
        </IfVersion>
    </Files>

# For 404s and 403s that aren't handled by the application, show plain 404 response
ErrorDocument 404 /pub/errors/404.php
ErrorDocument 403 /pub/errors/404.php

################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

    #FileETag none

# ######################################################################
# # INTERNET EXPLORER                                                  #
# ######################################################################

# ----------------------------------------------------------------------
# | Document modes                                                     |
# ----------------------------------------------------------------------

# Force Internet Explorer 8/9/10 to render pages in the highest mode
# available in the various cases when it may not.
#
# https://hsivonen.fi/doctype/#ie8
#
# (!) Starting with Internet Explorer 11, document modes are deprecated.
# If your business still relies on older web apps and services that were
# designed for older versions of Internet Explorer, you might want to
# consider enabling `Enterprise Mode` throughout your company.
#
# https://msdn.microsoft.com/en-us/library/ie/bg182625.aspx#docmode
# http://blogs.msdn.com/b/ie/archive/2014/04/02/stay-up-to-date-with-enterprise-mode-for-internet-explorer-11.aspx

<IfModule mod_headers.c>

    Header set X-UA-Compatible "IE=edge"

    # `mod_headers` cannot match based on the content-type, however,
    # the `X-UA-Compatible` response header should be send only for
    # HTML documents and not for the other resources.

    <FilesMatch "\.(appcache|atom|bbaw|bmp|crx|css|cur|eot|f4[abpv]|flv|geojson|gif|htc|ico|jpe?g|js|json(ld)?|m4[av]|manifest|map|mp4|oex|og[agv]|opus|otf|pdf|png|rdf|rss|safariextz|svgz?|swf|topojson|tt[cf]|txt|vcard|vcf|vtt|webapp|web[mp]|webmanifest|woff2?|xloc|xml|xpi)$">
        Header unset X-UA-Compatible
    </FilesMatch>

</IfModule>

Also go to the app folder from the root magento 2 directory , open the file bootstrap.php and uncomment this line - ini_set('display_errors', 1);

 

Also can you check your log file var/log directory and post the log - what exactly is there in error log file.

 

 

if issue solved,Click Kudos & Accept as Solution

Re: 500 ERROR

This goes in the magento root directory?  Not the setup directory.

** Dell Optiplex 9010, Intel Core I5, 16GB Memory, Centos 7.4 **
** PHP 7.1.16, MariaDB 10.1.11 **

Re: 500 ERROR

Yes this goes in Magento 2 root directory.

 

Also uncomment that line so you will get error display on the browser - what error it have !!

if issue solved,Click Kudos & Accept as Solution

Re: 500 ERROR

I have replaced .htaccess in magento root

 

Errors from the page are follows

-------------------------------------------------------------------

Warning: realpath(): open_basedir restriction in effect. File(/tmp) is not within the allowed path(s): (/home/Web/devel1:/home/web/tmp) in /home/Web/devel1/vendor/magento/framework/Filesystem/DirectoryList.php on line 99

Fatal error: Uncaught Exception: Warning: realpath(): open_basedir restriction in effect. File(/tmp) is not within the allowed path(s): (/home/Web/devel1:/home/web/tmp) in /home/Web/devel1/vendor/magento/framework/Filesystem/DirectoryList.php on line 99 in /home/Web/devel1/vendor/magento/framework/App/ErrorHandler.php:61 Stack trace: #0 [internal function]: Magento\Framework\App\ErrorHandler->handler(2, 'realpath(): ope...', '/home/Web/devel...', 99, Array) #1 /home/Web/devel1/vendor/magento/framework/Filesystem/DirectoryList.php(99): realpath('/tmp') #2 /home/Web/devel1/vendor/magento/framework/App/Filesystem/DirectoryList.php(176): Magento\Framework\Filesystem\DirectoryList->__construct('/home/Web/devel...', Array) #3 /home/Web/devel1/setup/src/Magento/Setup/Mvc/Bootstrap/InitParamListener.php(262): Magento\Framework\App\Filesystem\DirectoryList->__construct('/home/Web/devel...', Array) #4 /home/Web/devel1/setup/src/Magento/Setup/Mvc/Bootstrap/InitParamListener.php(96): Magento\Setup\Mvc\Bootstrap\InitParamListener->cre in /home/Web/devel1/vendor/magento/framework/App/ErrorHandler.php on line 61 

 

---------------------------------------------------------------------------------

 

ok, I think, I see the problem Smiley Happy, it appears to be with the /tmp dirctory? well an that I should have turned logging on 

 

 

 

 

** Dell Optiplex 9010, Intel Core I5, 16GB Memory, Centos 7.4 **
** PHP 7.1.16, MariaDB 10.1.11 **

Re: 500 ERROR

Yes you have issue with your configuration.

 

Below is the solution : 

 

To resolve this error, you must edit the file httpd.conf.

 

Way before it can be seen in phpinfo in apache2handler section directive Server Root.

 

For example, in my case this way - / etc / httpd / httpd.conf.

 

Open the file httpd.conf, find the mention of the parameter open_basedir. And set it to none. (php_admin_value open_basedir none)

 

 

It is the issue of server configuration currently you value is set to php_admin_value open_basedir /tmp directory but it should be set to none

if issue solved,Click Kudos & Accept as Solution