cancel
Showing results for 
Search instead for 
Did you mean: 

Admin buttons do not work

Admin buttons do not work

I have just installed a fresh copy of Magento 2.0.4.  It is running on a Linux cPannel host.  For some reason I cannot click on any of the buttons in the Admin section other than Dashboard and user settings.

 

All of the hyperlinks are ending in /# and there is no response when they are clicked.

 

How do i go about fixing this issue?

6 REPLIES

Re: Admin buttons do not work

Hi @nUm81

 

Try to run following command on Magento root

php bin/magento setup:static-content:deploy

It should solve the issue for you.

 

---
Problem Solved Click Accept as Solution!:Magento Community India Forum

Re: Admin buttons do not work

OK, i have tried running the command, however it seems as though it is only deploying the "frontend" folder, and then only the "frontend/Magento/blank/en_AU/"

 

It is also creating a "_requirejs" folder with the same sub structure.

 

It doesn't not seem to be doing a full deploy.

Re: Admin buttons do not work

Ok, so I have managed to fully deploy both the en_AU and en_US by just repeating the static deploy command until it successfully completed.

 

However this has not fixed the links in the Admin dashboard.

 

All of the links however are still broken, for example the System link;

 

<a href="#" onClick="retrun false;" class>
::before
<span>System</span>
</a>

Re: Admin buttons do not work

How to fix the problem of loading css and javascript files? https://mage2.pro/t/259 

Re: Admin buttons do not work

I have given up on Magento, it shouldn't be that difficult to install and run a application.  I have switched to another ecommerce solution.

 

 

Re: Admin buttons do not work

What browser were you using?

If you are unable to click buttons/links while using Firefox, please try Chrome.