cancel
Showing results for 
Search instead for 
Did you mean: 

Backend - Menu does not redirect

SOLVED

Backend - Menu does not redirect

Hi everybody!

 

I have some experience in Magento 1.xxx and installed 2.05 CE on a local xampp server.

But unfortunately the backend does not work.

At first, there seem to be many missing characters - you can have a look at this on the screenshot at the end of this post.

But my main problem is, that the links in the menu bar (Products, customers,.. ect.) don't work. They simply don't redirect - nothing happens.

I also downloaded the package again and installed again a few times with different database collations, but nothing was successful.

What am I doing wrong?

 

I installed Magento on a local xampp server with database collation utf8_unicode_ci.

No problems during installation. Apart from that, the shops language was not set correctly - during installation I chose "german", but front- and backend are still in english.

 

Thank you for your help!

Best regards
Christoph

 

Backend Menu - missing characters

 

7 REPLIES

Missing JS Files?

So, I found out, that the backend should use an hover effect to display submenu items.

But the hover doesn't work, so I found out that there are missing some JS files.

for example do

/pub/static/adminhtml/Magento/backend/en_US/mage/requirejs/mixins.js

or

/pub/static/adminhtml/Magento/backend/en_US/requirejs/require.js

not exist.

 

Re: Missing JS Files?

Hello,

 

The files in the pub/static directory are auto-generated.

 

Check if there is .htaccess file in the static directory:

pub/static/.htaccess

 

 

Also check if your magento is running in "developer" or "default" mode:

 

bin/magento  deploy:mode:show

 

 

You can force developer mode by adding the line:

 

   SetEnv MAGE_MODE developer

 

into the file:

magento_installation_dir/.htaccess 

 

 

 

Then refresh magento cache.

 

 

---------------------------------------------------------------------

 

 

If it does not help

 

 

Then modify two files:

vendor/magento/framework/Filesystem/DriverInterface.php
line 20

    const WRITEABLE_DIRECTORY_MODE = 0755;

 

line 25

    const WRITEABLE_FILE_MODE = 0644;

 


lib/internal/Cm/Cache/Backend/File.php
lines 50-51

'directory_mode' => 0755,
'file_mode' => 0644,

 


to make it temporarily set 0755 0644 permissions.


If it works then you should set up permissions correctly:

http://devdocs.magento.com/guides/v2.0/install-gde/prereq/apache-user.html#install-update-depend-use...

 

 

Stanislav

Re: Missing JS Files?

Hey!

 

Thank you very much for your reply!

 

Because I'm running magento via xampp on a windows OS, I could not check for developer mode via linux command.

And of course I couldn't refresh magento's cache, because the backend does not work. Or is there a possibility, to delete cache without the backend?

 

But everything else I did just as you said - unfortunately it didn't work.

It is still not possible to click any menu item in the backend.

 

I also tried to modify permissions via windows, but this also didn't work.

 

I have no idea how to get magento to work - i tried for at least a week by now.

I hope, someone can give a hint on how to solve my issues.

 

Thanks in advance

Christoph

Oh, no linux cmd ^^

Oh, I see, this was no linux command (bin/magento deploy:mode:show).

Sorry, I'm not that familiar with console operations.

 

anyway got an error, I guess I am doing something wrong (It says, that the command "bin" does not exist).

 

C:\xampp\htdocs\ubroo>bin/magento deploy:mode:show
Der Befehl "bin" ist entweder falsch geschrieben oder
konnte nicht gefunden werden

 

But I set developers mode manually anyway - so this post should only be an additional information.

 

Thank you!

 

 

 

 

Re: Oh, no linux cmd ^^

Hello,

 

On Windows commands should be like:

cd full_path_to_magento_directory_here

php bin/magento deploy:mode:show

 

 

Alternative solution by modifying app/etc/di.xml file described on youtube:

https://community.magento.com/t5/Installing-Magento-2/Magento-Backend-won-t-work-Unclickable-Buttons...

 

 

 

Stanislav

Works now!

Great! Thank you very much!

Deleting the content of pub/static (except .htaccess file)
and editing the di.xml (and maybe also using "127.0.0.1" instead of "localhost") made it work!

 

I could be happy now, but can anyone explain, what the problem was?

So, I see that the problem was - just as I thought - actually the missing the JS files.

But why weren't they generated or copied correctly? I don't get it.

 

Again, thank you very much!

Best regards

Christoph

 

Re: Works now!

Hello,

 

The .js files in the pub/static directory were not generated because Magento file system owner was not set correctly:

http://devdocs.magento.com/guides/v2.0/install-gde/prereq/apache-user.html#install-update-depend-use...

 

 

 

Stanislav