cancel
Showing results for 
Search instead for 
Did you mean: 

Backend missing js

SOLVED

Backend missing js

Hello dear community,

 

I'm already trying to setup magento completely for 1 week now.

I have never thought that I would have such trouble with it ...

 

Actually I'm facing the problem that the backend is missing some javascript files (Error 404).

Due to the missing js files, I can't use the backend properly.

 

Missing files: http://abload.de/img/jsmissingvwods.png

 

I'm running Magento 2 on a GoDaddy VPS with Apache 2.4 Server.

 

This is what I already tried:

- Manually flushed cache and static content

- Deployed Static Content

- Changed symlinks to copy (app/etc)

- Changed permissions to 644/755 (following the steps in installation-documentation http://devdocs.magento.com/guides/v2.0/install-gde/prereq/file-system-perms.html did NOT work for me)

- Changed permissions in DriverController to 644/755

- Tried several options in htaccess for static folder (e.g. Options -MultiView..)

 

The /pub/static folder does NOT contain the files after running the deploy-static command. I'm not sure how to get the files in the pub/static folder.

 

The Frontend is running fine at the moment. (At the beginning I had a similiar problem with missing js/css/img files on Frontend, 'DriverController permission replace' fixed that)

 

Unfortunately I wasn't able to find any information about how to solve my problem using Google.

Hopefully you can help me. Thanks in advance!

3 REPLIES

Re: Backend missing js

Hi @Hawk30100

 

Did you go through following url Deploy static view files it may help you.

Did you try to deploy static content using following command php bin/magento setup:static-content:deploy

---
Problem Solved Click Accept as Solution!:Magento Community India Forum

Re: Backend missing js

Thanks for this fast answer.

 

Yes, I already tried to deploy the static content several times.

Cuz I'm using the language en_CA, I also deployed the content for en_CA, but the scripts are also missing.

So actually I've got two static deployments and both are missing these 4 javascript files.

Re: Backend missing js

I just found the problem... i deleted and generated the static folder again and again... but I didn't noticed that the owner of this folder was the wrong one. The files were generated by root... for my usage on the virtual private server I have to change the ownership of these files.

 

So, make sure your ownership is set correctly Smiley Wink