cancel
Showing results for 
Search instead for 
Did you mean: 

CSS / Images / JS Not loading

CSS / Images / JS Not loading

So I'm new to Magento 2 and installing Magento 2 on a small server before we purchase Enterprise Ed.  Install went very smooth and followed the documentation (I thought).  When finished, the CSS, image, and JS is not loading.  There are many post I see about the issue and have tried everything I seen.  I know I'm missing something simple here.

 

The rewrite module is installed on the server and enabled.  I have tried the following, 

php bin/magento setup:static-content:deploy
php bin/magento indexer:reindex

However,  when logging into SSH as root,  I do not have 'magento' in the bin directory.  Although the commands do work, I get the following WARNINGS: 

 

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/ex tensions/no-debug-non-zts-20121212/php_soap.dll' - /usr/local/lib/php/extensions /no-debug-non-zts-20121212/php_soap.dll: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/ex tensions/no-debug-non-zts-20121212/apc.so' - /usr/local/lib/php/extensions/no-de bug-non-zts-20121212/apc.so: cannot open shared object file: No such file or dir ectory in Unknown on line 0

 

 

 

 

 

 

1 REPLY

Re: CSS / Images / JS Not loading

I did finally find a post that helped. 

cd /var/www/html/magento

1: rm -rf var/di/* var/generation/* var/cache/* var/page_cache/* var/view_preprocessed/* var/composer_home/cache/*

2: sudo chmod 777 var -R
3: sudo chmod 777 pub -R

4: sudo php bin/magento setup:static-content:deploy

5: Repeat step 2 & 3.

 

After doing this, everything loaded fine.  However, while in the admin panel of magento, all the thumbnails of products are missing.  Is there anything else I can do?