cancel
Showing results for 
Search instead for 
Did you mean: 

CSS not loading in the front and backend after installing via Installatron Script

SOLVED
Highlighted

Re: CSS not loading in the front and backend after installing via Installatron Script

Thanks sivaselvanaerp, It solved my issue.

Highlighted

Re: CSS not loading in the front and backend after installing via Installatron Script

Hi prakashchand,

Can you please let me know how you have solved it? Same problem here.

Highlighted

Re: CSS not loading in the front and backend after installing via Installatron Script


@sivaselvanaerp wrote:

If you redeployed  it after deleting the pub/static directory you would have deleted the .htaccess file in pub/static directory. That causes the URL Rewrite issue. Put the .htaccess with urlrewrite option in the pub/static directory , will resolve the problem. 


Thank you so much, this solved my problem

View solution in original post

Highlighted

Re: CSS not loading in the front and backend after installing via Installatron Script

thanks, you saved me

Highlighted

Re: CSS not loading in the front and backend after installing via Installatron Script

After trying all these methods and getting no where besides the static folder, this works perfect first time using xampp:

 

 $ cd /var/www/html/magento2 - wamp

 

$ cd C:\xampp\htdocs\magento2 - xampp

 https://community.magento.com/t5/Installing-Magento-2-x/Magento-2-2-3-with-sample-data-install-seem-...

 

php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento setup:static-content:deploy -f
php bin/magento cache:clean
php bin/magento cache:flush

 777 the directory commands didnt work though

2.2.3 now installed and operational front and back simple when you know how. Thanks!

Highlighted

Re: CSS not loading in the front and backend after installing via Installatron Script

indexers need update to:

 

cd C:\xampp\htdocs\magento2 - xampp

 

php bin/magento indexer:reindex

 then goto cache management in admin and flush selected.

Highlighted

Re: CSS not loading in the front and backend after installing via Installatron Script

css and js comes back but its not working properly

Highlighted

Re: CSS not loading in the front and backend after installing via Installatron Script

Please follow these steps for load all js and css

windows users

$ cd /var/www/html/magento2
$ php bin/magento setup:static-content:deploy
$ php bin/magento indexer:reindex

and for linux users

follow above steps and now

$ chown -R www-data:www-data /var/www/html/magento2

 

$ chmod -R 775 /var/www/html/magento2/ 
$ chmod -R 777 /var/www/html/magento2/var/
$ chmod -R 777 /var/www/html/magento2/pub/

 delete cache folder under var/cache

Highlighted

Re: CSS not loading in the front and backend after installing via Installatron Script


Step 5.

$ chmod -R 777 /var/www/html/magento2 

 


Are you serious?? chmod 777 ??? 

Highlighted

Re: CSS not loading in the front and backend after installing via Installatron Script

I found out that it was pub/.htaccess file which is causing the problem.  You remove or rename that file to orig.htaccess, and give a try.

 

Or use the following .htaccess file:

 

############################################
## Optional override of deployment mode. We recommend you use the
## command bin/magento deploy:mode:set to switch modes instead

# Options are default, production, or developer
# SetEnv MAGE_MODE default

############################################
## Uncomment these lines for CGI mode.
## Make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

# Action php5-cgi /cgi-bin/php5-cgi
# AddHandler php5-cgi .php

############################################
## GoDaddy specific options

# Options -MultiViews

## You might also need to add this line to php.ini
## cgi.fix_pathinfo = 1
## If it still doesn't work, rename php.ini to php5.ini

############################################
## This line is specific for 1and1 hosting

#AddType x-mapp-php5 .php
#AddHandler x-mapp-php5 .php

############################################
## Default index file

DirectoryIndex index.php

<IfModule mod_php5.c>
############################################
## Adjust memory limit

php_value memory_limit 768M
php_value max_execution_time 18000

############################################
## Disable automatic session start
## before autoload was initialized

php_flag session.auto_start off

############################################
## Enable resulting html compression

#php_flag zlib.output_compression on

###########################################
# Disable user agent verification to not break multiple image upload

php_flag suhosin.session.cryptua off
</IfModule>
<IfModule mod_php7.c>
############################################
## Adjust memory limit

php_value memory_limit 768M
php_value max_execution_time 18000

############################################
## Disable automatic session start
## before autoload was initialized

php_flag session.auto_start off

############################################
## Enable resulting html compression

#php_flag zlib.output_compression on

###########################################
# Disable user agent verification to not break multiple image upload

php_flag suhosin.session.cryptua off
</IfModule>


<IfModule mod_security.c>
###########################################
# Disable POST processing to not break multiple image upload

SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

<IfModule mod_deflate.c>

############################################
## Enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

# Insert filter on all content
###SetOutputFilter DEFLATE
# Insert filter on selected content types only
#AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript

# Netscape 4.x has some problems...
#BrowserMatch ^Mozilla/4 gzip-only-text/html

# Netscape 4.06-4.08 have some more problems
#BrowserMatch ^Mozilla/4\.0[678] no-gzip

# MSIE masquerades as Netscape, but it is fine
#BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

# Don't compress images
#SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

# Make sure proxies don't deliver the wrong content
#Header append Vary User-Agent env=!dont-vary

</IfModule>

<IfModule mod_ssl.c>

############################################
## Make HTTPS env vars available for CGI mode

SSLOptions StdEnvVars

</IfModule>

<IfModule mod_rewrite.c>

############################################
## Enable rewrites

Options +FollowSymLinks
RewriteEngine on

############################################
## You can put here your magento root folder
## path relative to web root

#RewriteBase /magento/

############################################
## Workaround for HTTP authorization
## in CGI environment

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## TRACE and TRACK HTTP methods disabled to prevent XSS attacks

RewriteCond %{REQUEST_METHOD} ^TRAC[EK]
RewriteRule .* - [L,R=405]

############################################
## Never rewrite for existing files, directories and links

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

############################################
## Rewrite everything else to index.php

RewriteRule .* index.php [L]

</IfModule>


############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

AddDefaultCharset Off
#AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

ExpiresDefault "access plus 1 year"
ExpiresByType text/html A0
ExpiresByType text/plain A0

</IfModule>

###########################################
## Deny access to release notes to prevent disclosure of the installed Magento version

<Files RELEASE_NOTES.txt>
order allow,deny
deny from all
</Files>

# For 404s and 403s that aren't handled by the application, show plain 404 response
ErrorDocument 404 /errors/404.php
ErrorDocument 403 /errors/404.php

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

#FileETag none

###########################################
## Deny access to cron.php
<Files cron.php>
order allow,deny
deny from all
</Files>

<IfModule mod_headers.c>
############################################
## Prevent clickjacking
Header set X-Frame-Options SAMEORIGIN
</IfModule>