cancel
Showing results for 
Search instead for 
Did you mean: 

Can not log into Admin after fresh install

SOLVED

Can not log into Admin after fresh install

Hello there

 

I have successfully install a Centos Vagrant box with Magestead (http://www.magestead.com/). This worked and I was able to log into the Admin section.

 

I am more comfortable using Ubuntu, so I created a new vagrant box using Ubuntu. I set it up as per the documentation and installed Magento without any issues. I have set up the correct file permissions etc. However, when I try and access the admin section, I receive the following error. The front pages work fine btw.

 

Warning: file_get_contents(/var/www/html/magento2/var/cache//mage-tags/mage---ea6_BACKEND_MAINMENU): failed to open stream: No such file or directory in /var/www/html/magento2/lib/internal/Cm/Cache/Backend/File.php on line 614

I have tried clearing the pub/static folder, cleared the various var/ directories as suggested in other posts etc. 

 

Thinking it might be an issues with the vagrant shared folders. I started again and this time installed Magento on a folder inside the vagrant box (not on the folder share). This was a lot quicker so I hoped that this might have been the reason. Alas, this did not solve my problem and I still receive the same error.

 

I have tried the composer install and the manual compressed download install but I have the same error on both.

 

Looking at the location of the missing file, I can confirm that the file is not there. When I look at the Centos box, this file is there. If I remove the folder on the Centos box (var/www/html/magento2/var/cache/), the file gets created as expected and works fine. This does not happen with the Ubuntu box, however some of the mage---ea6 files are created so it's doing it stuff.

 

Does anyone have any ideas?

1 REPLY

Re: Can not log into Admin after fresh install

So I figured it out after some testing.

It turned out to be xDebug (or the way I was installing it) that was causing the issue. I ran some tests and the admin areas worked fine with xDebug not installed.

I needed Xdebug for development reasons so I installed it using Pear and Magento installed fine with everything working correctly!