cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot install magento 2.1.1

Cannot install magento 2.1.1

Hi,
I'm trying to load magento 2.1.1 on unix server but when it does system check I keep on getting following error message and application will not load.

Your PHP Version is 5.6.22, but always_populate_raw_post_data = 0. $HTTP_RAW_POST_DATA is deprecated from PHP 5.6 onwards and will be removed in PHP 7.0. This will stop the installer from running. Please open your php.ini file and set always_populate_raw_post_data to -1. If you need more help please call your hosting provider.

After using:

<?php phpinfo(); ?>

I get:

Configuration File (php.ini) Path      /opt/alt/php56/etc

Loaded Configuration File         /home/some9753/public_html/php.ini

Scan this dir for additional .ini files         /opt/alt/php56/link/conf

Additional .ini files parsed       /opt/alt/php56/link/conf/alt_php.ini

 

I don't have access to the directories /opt/alt/php56/etc, apart from that in the php info file always_populate_raw_post_data is set to -1 for Local Value as well as Master Value.

The Loaded Configuration File php.ini was created by myself and and placed in public_html folder. It contains:

always_populate_raw_post_data = -1;

But it is not solving problem. I don't know how the installer is coming up with always_populate_raw_post_data = 0 when it is not set to that value anywhere. Any suggestion as to what I should do to solve problem? There's some kind of conflict which needs to be resolved. All help will be greatly appreciated.

3 REPLIES

Re: Cannot install magento 2.1.1

I assume you do not have access to the loaded .ini file as you are on shared hosting, is this correct?

Re: Cannot install magento 2.1.1

Hello, Thanks for your reply. No I do not have access to the loaded .ini file although my hosting provider keeps telling me that always_populate_raw_post_data = -1 in .ini file

Highlighted

Re: Cannot install magento 2.1.1

It can be really tricky when you are on shared hosting and have no control over a parameter. But I can understand that the hosting provider has to ensure the settings are the same for all clients. Could you possible pop a phpinfo.php file in your site root with the following contents:

 

<?php
phpinfo();
?>

And paste the results in this thread, should help understand what is set globally and what is overridden locally.