cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot install with Composer because of errors.

SOLVED

Cannot install with Composer because of errors.

I want to install Magento 2 locally on Windows with Wampserver, in CLI I input:

 

composer create-project --repository-url=https://repo.magento.com/ magento/project-community-edition <installation directory name>

 

The process  goes along nicely, I see that it created a project, that it load composer repositories with package information, but once it goes to the part of Updating dependancies (including require-dev) it says:

 

Problem 1

- Installation request for magento/product-community-edition 2.1.0 -> satisfiable by magento/product-community-edition[2.1.01].

- magento/product-community-edition 2.1.0 requires php ~5.60|7.0.02|~7.0.6 -> your PHP version (7.0.0) does not satifisfy that requierement.

 

 

The second part, sure, I understand, PHP version not good, I changed this in Wampserver but it still used the Composer's 7.0.0, but it is something I will get to work, but that first line is the problem I want to solve first,

'satisfiable by ..." what do they want to say with thay?

 

 

Also, as I have tried this on several computers, at another computer I got that it could not find the repository. But that was just once.

Does anybody know what I need to do to fix this? Also, how long does it take for everything to be downloaded?

 

1 REPLY

Re: Cannot install with Composer because of errors.

I changed my php version , but now it says:

 

InvalidArgumentException

Could not find package with stability stable

 

Not really related to above problem, but just wanted to point out how cumbersome this process is.

 

 

EDIT: I have managed to install with Composer, the problem was that Windows did not accept too many characters in their file-system, I changed the name of the folder and that solved it.