cancel
Showing results for 
Search instead for 
Did you mean: 

Composer Create Project Fails With Stability Error

Highlighted

Composer Create Project Fails With Stability Error

I am following the docs located at:

https://devdocs.magento.com/guides/v2.3/install-gde/composer.html

 

When running the command

 composer create-project --repository-url=https://repo.magento.com/ magento/project-community-edition <install-directory-name>

I get the error:

 

  [InvalidArgumentException]
  Could not find package magento/project-community-edition with stability stable.

I also tried passing every one of the stability flags using -s as well and trying to pass a specific version number in the command to no avail

 

It appears that two other developers were able to confirm that they are also having the same issue(s) in the community Slack channel.

 

Is there currently an issue with the repository or the latest published package(s)? 

 

Thanks.

8 REPLIES 8
Highlighted

Re: Composer Create Project Fails With Stability Error

Getting same. 
Let me know if you solve this issue somehow, please
Thanks

I know i can still clone it from github, but, I prefer to composer it.

Is there someone who managed to solve this issue?

Highlighted

Re: Composer Create Project Fails With Stability Error

I can confirm this is happening on two of my environments, create-project was working fine last week. I think this is an issue with the repository or authentication keys. 

At least we know we're not the only ones with this issue.

Highlighted

Re: Composer Create Project Fails With Stability Error

Definitely seems like something's up. I've been getting Invalid Credential errors all day. The same keys were working last week and a new set of auth keys has not fixed it.

Highlighted

Re: Composer Create Project Fails With Stability Error

I confirm same problem when installing and updating Magento and any extension on different servers and environments, I think this is temporary problem with the Magento's repo (repo.magento.com). 

 

This issue started 2 hours ago. Please reply and raise this post so the maintainers of the Magento repository resolve it hopefully soon!

 

Below is the error text (This was fine two hours ago on the same server - nothing changed):

 

27 May 2020 00:30 GMT:

Check Component Dependency

Problem 1 - The requested package magento/product-community-edition could not be found in any version

Highlighted

Re: Composer Create Project Fails With Stability Error

It's working for me now.

Highlighted

Re: Composer Create Project Fails With Stability Error

After seeing replies from other folks and being able to test the create-project command again this morning, I can confirm that  whatever issue was causing problems has been resolved.

 

It would be great if we can get information on what the issue was or if we should look out when future changes are made to the repo or when packages are pushed in order to more effectively use our time with Magento in the future.

 

I know that cloning from the Github src or an archive tarball and then composer installing was a potential workaround in case anyone comes across this issue again, but I am uncertain if this produces the exact same result as running create-project with the community meta package.

 

Thanks for everyone who replied.

 

 

Highlighted

Re: Composer Create Project Fails With Stability Error

Yes I confirmed that this problem was resolved the next morning, but in the same day I started getting "Bad credentials" error on the "Extension Manager" page. same keys and I am 100% sure they are valid and without any extra spaces. I wonder if anyone is getting the same error since yesterday!

Highlighted

Re: Composer Create Project Fails With Stability Error