cancel
Showing results for 
Search instead for 
Did you mean: 

Could not determine temp directory, please specify a cache_dir manually

SOLVED

Could not determine temp directory, please specify a cache_dir manually

Hello,

 

I have problems with cache_dir.

I have the file.php file adjusted . In the Magento panel, is still the error Could not determine temp directory, please specify a cache_dir manually
 
/lib/internal/Cm/Cache/file.php
 
/** @var array */
    protected $_options = array(
        'cache_dir' => 'var/tmp/',            // Path to cache files
        'file_name_prefix' => 'cm',            // Prefix for cache directories created
        'file_locking' => true,                     // Best to keep enabled
        'read_control' => false,                // Use a checksum to detect corrupt data
        'read_control_type' => 'crc32',    // If read_control is enabled, which checksum algorithm to use
        'hashed_directory_level' => 2,    // How many characters should be used to create sub-directories
        'use_chmod' => FALSE,              // Do not use chmod on files and directories (should use umask() to control permissions)
        'directory_mode' => 0770,          // Filesystem permissions for created directories (requires use_chmod)
        'file_mode' => 0660,                    // Filesystem permissions for created files (requires use_chmod)
 
System:
Windows 2012 r2 with IIS 8.5
 
1 REPLY

Re: Could not determine temp directory, please specify a cache_dir manually

 

I found the solution

 

Set sys_temp_dir in php.ini to a path that can be reached by IUSR then restart IIS to apply changes.