cancel
Showing results for 
Search instead for 
Did you mean: 

Debian and intl and cron jobs - PHP Fatal error

SOLVED

Debian and intl and cron jobs - PHP Fatal error

Hello,

 

every suggestions i've found was about xamp / wamp and windows configuration of intl. In debian i tried:

apt-get install php5-intl

 

and that works for first step of installation Magento 2.0 but, there are next steps to setup cron jobs.

like that:

*/1 * * * * php -c <ini-file-path> <your Magento install dir>/bin/magento cron:run 
*/1 * * * * php -c <ini-file-path> <your Magento install dir>/update/cron.php 
*/1 * * * * php -c <ini-file-path> <your Magento install dir>/bin/magento setup:cron:run 

So at first before adding it to cron i've tried to fire those scripts like that:

php /var/www/mysite.com/web/bin/magento cron:run

but i have those errors:

PHP Fatal error:  Class 'IntlDateFormatter' not found in /var/www/clients/client1/web2/web/vendor/magento/framework/ObjectManager/Factory/AbstractFactory.php on line 107

i also added to php.ini this line because i didn't have it before even with semicolon:

extension=php_intl.dll

but that produces another warning, when firing script above:

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20131226/php_intl.dll' - /usr/lib/php5/20131226/php_intl.dll: cannot open shared object file: No such file or directory in Unknown on line 0

and i don't have anykind of icudt36.dll, icuin36.dll, icuio36.dll, icule36.dll, iculx36.dll, icutu36.dll, icuuc36.dll - nowhere 

 

My phpinfo() about intl:

 

Additional .ini files parsed        /etc/php5/cgi/conf.d/20-intl.in

intl
Internationalization support	enabled
version	1.1.0
ICU version	55.1
ICU Data version	55.1
Directive	Local Value	Master Value
intl.default_locale	no value	no value
intl.error_level	0	0
intl.use_exceptions	0	0

Any help would be appreciated

 

Tags (1)
1 REPLY

Re: Debian and intl and cron jobs - PHP Fatal error

Problem solved.

At first i have added to /var/php5/cgi/php,ini:

 

extension=intl.so

 

second changed command to:

 

php -c /var/php5/cgi/php.ini /var/www/mysite.com/web/bin/magento cron:run

 

and it is working Smiley Happy

 

to make it work without -c and php.ini url - i was needed to add exntension=intl.so to:

 

/etc/php5/cli/php.ini